"Postprocessor Error - Broken connection" when post processing NC code with opt file in PowerMill

Autodesk Support

Jun 3, 2024


Products and versions covered


Issue:

User reported that when post processing NC code with opt file in PowerMill, the errors are displayed:

 Postprocessor Error - Broken connection.
Postprocessor Error - Broken Connection

Postprocessor Error - Failed to get translator version from the registry.
Ensure that DuctPost is installed and that it has been registered correctly.

Failed to get translator version from registry
 
 

Environment:

Ductpost postprocessor.

Causes:

For PowerMill version 2016 and before:

  • In versions of PowerMill before 2017, the PAF file and USB dongle are not installed in the computer.

For PowerMill version 2017 and after:

  • DuctPost is not installed with versions of PowerMill 2017 and after which causes an error when posting with an opt file.
  • DuctPost needs updating to the dongle-free version 1.6.10.

Solution:

To resolve the problem in PowerMill 2017 and later, do one of the following:

  • Have any OPT(*. opt) files migrated to PMOPTZ(*. pmoptz) files by contacting a trusted partner/reseller.
Note: This is the best option for "future-proofing" your postprocessor.
  • Install the copy of Ductpost attached to this article.
Note: The attached copy of Ductpost does not require a PAF file or Dongle.

To resolve the problem in PowerMill 2016 and earlier:

  • Delete any notes under File > Project Settings > Notes.
  • Install the Sentinel driver for the USB dongle.
  • Make sure that the PAF file and USB dongle are installed.
Note: When installing PowerMill or Ductpost, the Windows User Account Control (UAC) is set to "never notify" and install as administrator.

Attachments:

DuctPost_1.zip;

Products:

PowerMill;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support