Cannot open or save file with audit in Revit

Autodesk Support

Jul 26, 2024


Products and versions covered


Issue:

Users reported that when using the Audit checkbox or attempting to purge, specific Revit models fail to open or save.

Messages similar to the following are received:
  • Data in file <filename>.rvt is corrupt and needs to be manually recovered.
  • The model <filename>.rvt is missing many elements, and it cannot be opened.
  • The file <filename>.rvt is cannot be opened. There are too many missing elements in it. Please contact Autodesk Support.
  • Assertion failed: line 797 of ElemTable\Marshaller.cpp
  • A fatal error has occurred.  The application will be terminated.  You have the opportunity to save recovery files for all of your changed projects.
  • An unrecoverable error has occurred.  The program will now be terminated.  All of your data has been recently saved, so there is no need to create recovery files." 

Causes:

A corrupt family is causing this error.

Entries similar to the following will be recorded in the journal files:
DBG_WARN: (asynchronous i.e. previously detected)Why no ElemRec?: line 119 of OwnerGraph\KingOf.cpp.
DBG_WARN: (asynchronous i.e. previously detected)Missing owner, or cycle of owners!: line 113 of OwnerGraph\KingOf.cpp.
DBG_WARN: Failed to translate big ElemId.: line 217 of Family\FamilyDocument.cpp.


 

Solution:

To find the problematic family, go through the following steps:

  1. Open the model without using the Audit checkbox.
  2. Export a library of all the families.
  3. If there is an error when exporting a particular family (for example Family <family name> could not be saved), note down the name of the family.
  4. If there is a general error ("too many missing elements", "Data in <file name>.rvt is corrupt", "Assertion failed"), look at the status bar of the Revit window for the family that is being exported.
  5. Reload the families identified in step 3 and 4 (when reloading make sure you are prompted to overwrite the parameter values, if this does not come up then it is not actually being reloaded) or delete from the model and retest (if the issue continues, try exporting again to see if there is more than one problematic family).
Note: If the error continues after deleting the family reloaded/deleted in step 4 above, there may be more problematic families. To find them go through steps 1-4 again until all are identified.

Products:

Revit Product Family;


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