Cannot update linked tools in a catalog in AutoCAD Architecture or AutoCAD MEP

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

While trying to edit a tool on a custom tool palette that refreshes from a catalog in the Content Browser, the properties are greyed out and the tool cannot be modified.

Causes:

The refresh settings need to be cleared from the tool and the tool palette where it resides before the tool can be edited.

Solution:

Clear the refresh option for the tool palette

  1. Add the tool palette from the Content Browser catalog to the tool palettes in the workspace.
  2. Right-click the tool palette and select "Properties...".
  3. Uncheck the "Refresh from:" box, then OK.
Tool Palette Refresh From

Clear the refresh option for the tool

  1. Right-click the tool and select "Properties...".
  2. Uncheck the "Refresh from:" box, then OK.
Tool Refresh From Checked     Tool Refresh From Unchecked

Update the tool in the catalog

  1. Drag the updated tool from the palette to the corresponding location in the Content Browser.
  2. Select "Replace current with new..." when prompted.
Catalog Confirm Item Replacement

Restore the refresh settings for the tool, then the palette

  1. Right-click the tool and select "Properties...".
  2. Check the "Refresh from:" box, then OK.
  3. Right-click the tool palette and select "Properties...".
  4. Check the "Refresh from:" box, then OK.

Products:

AutoCAD Architecture; AutoCAD MEP;


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