"Clock Error Check that your system clock is set to the current date and time before you try again" when launching Autodesk software

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

While starting Autodesk software, it fails to load and displays the following message:
 

Clock Error

Check that your system clock is set to the current date and time before you try again.
 

Clock Error notification 

OR

Clock error message displayed on latest version of Autodesk products.
 
 
 

Environment:

  • Windows.

  • macOS.

Causes:

  • The error message is displayed if the time set is correct but a valid recorded email address was not put when requested.

  • The time set on the system is incorrect.

Solution:

To solve the issue: 

Set the system clock manually:

  1. Go to Start > Windows Settings.

  2. Select Time & Language.

  3. Select the Date & Time tab.

  4. Set the Time automatically: On.

  5. Set the Time zone automatically: On.

  6. Restart the computer if needed.
Clock setting in Windows 10

 

System time provided by a domain controller

In some instances, the options are dimmed and show the following disclaimer:

Date and time cannot be changed manually due to IT restriction of organization.

Your organization might have a domain policy that forces workstations to synchronize system time to a local NTP (Network Time Protocol) server which is serving an incorrect time.


Follow these steps on Windows

  1. Open an elevated Command prompt by typing cmd into the Start menu, then right-click cmd.exe and choose "Run as administrator”.

  2. Execute the commands the following commands (click ENTER after every command): 

net stop w32time

w32TM /config /syncfromflags:manual /manualpeerlist:time.windows.com
net start w32time
w32tm /config /update
w32tm /resync



Folow these steps on MacOS

  1. Go to the Apple menu > System Preferences > Date & Time.

  2. Check the box for “Set date and time automatically.”

Date and Time dialog box on macOS
Another additional solution that has helped would be to Uninstall and reinstall the Autodesk software.

 
 

Products:

All Cloud and Desktop Products;


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