Links are not visible in the BIM 360/ACC web viewer after publishing a Revit model

Autodesk Support

Apr 11, 2025


Products and versions covered


Issue:

Users reported that when linking files to a model and publishing, the links do not show up in BIM 360 Document Management or in Docs on the Autodesk Construction Cloud platform from Revit.

  • The linked models do not show up in BIM 360 Document Management or in Docs on the Autodesk Construction Cloud (ACC) platform.

  • The files are linked from the local machine or from the connected Autodesk Docs drive (Desktop Connector).

  • The links show correctly when viewing in Revit.

Causes:

  • The linked files are not saved as Cloud Models or Cloud Workshared Models.
  • The linked files were saved to BIM 360 Document Management or Docs (ACC platform) through file upload or drag into the browser.
  • The files are linked through Desktop Connector.
  • Files are linked from the local drive of the user. 
  • The cloud models are not published after linking.

Solution:

The Revit files are not cloud models

Each file needs to be published from Revit as a cloud work shared model or cloud model, and then linked to the central model from the cloud through External Resources:

For non-workshared models:

  1. Open the linked model.
  2. Click the File tab Save As icon (Save As).
  3. Select Cloud Model.
  4. In the Save as Cloud Model dialog, select the cloud project where the host model is stored, and click Save.
  5. Repeat the process for each linked Revit model.

For workshared models:

  1. Open the linked model.
  2. Click the Collaborate tabManage the Collaboration panelCollaborate icon (Collaborate).
  3. Select In the Cloud.
  4. Select the cloud project where the host model is stored and click Save.
  5. Revit displays information about the status of the process. Click Close to confirm.
  6. Repeat the process for each linked Revit model.

Then, proceed to the next part of the solution to link the cloud models correctly.

The cloud models are not linked correctly

Open the host model in Revit, and go to Manage > Manage Links. Look at the paths of the links.

  • If the path is Autodesk Docs://<project_name>/Project Files/... the link is linked correctly as a cloud link through External Resource. In this case, check the next solutions.
  • If the path is Autodesk Docs://<account_name>/<project_name>/Project Files/... the link is not linked correctly. This indicates the link is added through Desktop Connector as a non-cloud link. In this case:
    1. On the Revit tab of the Manage Links dialog box, select a linked model, and click Reload From.
    2. On the left-side panel go to External Resource.
    3. Find the linked file you are relinking, select it, and click Open.
    4. The cloud version of the link will be locally cached on the machine and loaded.
    5. Repeat the previous two steps to reload each linked model from the cloud location (External Resource).
    6. Click OK to close the Manage Links dialogue box.
    7. Synchronize and Publish the host model.
Import/link RVT - External Resources Icon from Revit


Note: This linking workflow through "External Resource" is limited to the cloud models within the same project. For ACC projects, Bridge allows transferring files between projects: About Bridge.

The cloud models are not published

Go on the Revit home page, navigate through the project, find the linked models, and click the 3 dot menu > Publish. Then, find the host model and do the same.

The wrong view is selected to be published

In Revit, go to Collaborate > Publish Settings, and make sure the 3D view showing all the links is selected in the published Set. Then sync and publish.

Products:

Revit Product Family; Revit Cloud Worksharing; BIM 360; Construction Cloud; Desktop Connector;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support