Copy and paste hangs, freezes, or crashes in AutoCAD Products

Autodesk Support

Dec 19, 2024


Products and versions covered


Issue:

Users reported that when trying to copy, paste, or select objects in an AutoCAD drawing, the process hangs for a long time. It may also:
  • Take several minutes to recover.
  • Freeze or fail to work.
  • Crash or throw a fatal error.

Causes:

  • Computer does not meet Recommended system requirements.
  • Data corruption in the drawing.
  • Selecting a high number of objects.
  • Outdated or corrupted Installation.
  • Outdated video card driver.
  • Many layer states are in use.
  • The scale between model space and paper space is different.

Solution:

System requirements

Verify that the computer meets the Recommended system requirements. See System Requirements for AutoCAD and Toolsets.

Software-specific solutions

Drawing-specific solutions

  • Reduce the amount of drawing content.
    • If there are many layers in a drawing, lock or freeze those that are not always necessary to have their content visible. This will reduce the amount of system resources needed to move around within the drawing editor.
    • Group objects together into blocks wherever appropriate. This will also help reduce the overall file size and improve performance.
    • Instead of copying and pasting the content to a new drawing, insert the drawing as a reference. See To Work With Attaching and Detaching Referenced Drawings.
  • Recover the drawing. Use the RECOVER command to open the drawing. This will audit the file and fix errors.
  • Remove excessive Line Types. Use the PURGE command and select all options to purge extra Line Types that may be in the drawing.
  • Delete constraints. Too many constraints will slow down a drawing and stop copy and paste from working. Often these are not visible in the drawing and can be turned on under the Parametric tab on the ribbon. To remove them, select all elements in the drawing and use the DELCON command.
  • Reset the scale list. Use the -SCALELISTEDIT command and choose the Reset option.
  • Delete layer filters. Use the FILTERS command to delete all layer filters.
  • Export Civil 3D objects from the problem drawing to a new drawing, using the LandXML tool. 
  • Use EXPORTTOAUTOCAD to create a version of the drawing with AutoCAD content only.
  • Use QSELECT to select splines and convert them to polylines using the steps in the Knowledge Article, see To Convert a Spline to a Polyline.
  • Use QSELECT to identify which types of components are causing the issue (Try for each component the COPY command). Delete or replace the identified objects.
  • When the issue appears when copying a block, the block might be corrupt. Explode the block before copying. A new definition of the block might change the behavior in case the block definition is needed.
  • Check and adjust the scale of pasted objects in paper space. See Using the Clipboard pastes objects in the wrong size in AutoCAD.
  • If there are duplicated defined block objects, need to redefine the block definitions. See Blocks cannot be inserted in AutoCAD drawing because of duplicate block definition.  
  • If multiple blocks are present in the drawing while using AutoCAD 2024 and up then follow the steps from this article: Performance degradation issue when editing block objects in AutoCAD Products 2024

Check the Layer States

AutoCAD merges the layer-states of all the Xrefs involved into one list. Merging is what takes time.
The AutoCAD UI (Ribbon) updates this internal layer state list after every drawing modification.
When typing LAYERSTATE on the command line, it takes some time for the dialog box to come up with a list of all the layer states. This happens after every edit operation, such as copy-paste.
To solve this:

  1. Open each Xref separately.
  2. COPY the drawing and PASTE in a new drawing space. By doing so AutoCAD only carries over the needed layers no layer state is carried over.
  3. Rebuild only the needed later state.

Environment-specific solutions

  • Memory fragmentation may have corrupted the clipboard. Exit and restart AutoCAD to reset it.
  • Save, close, and reopen the drawing. This can refresh the memory usage of the system.
  • Delete the contents of the temp folders. See How to delete temporary files in Windows.
  • Perform a system file check and check disk, see Performance issues and crashes in AutoCAD.
  • Turn Off Clipboard History in Windows Settings > System > Clipboard > Clipboard history.

Products:

AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;


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