Dialog box windows are not displayed in AutoCAD products

Autodesk Support

Oct 25, 2024


Products and versions covered


Issue:

When entering a command or clicking a button within an AutoCAD product, the Windows dialog (not program-specific palettes) does not open. 
  • The software may appear to lock up, freeze, or hang, and portions may gray out.
  • When the system volume is on, a "ding" sound may be heard when clicking the mouse in this state.
  • Control of the program may be restored when the Esc (Escape) key is pressed.
  • Commands and functions that may exhibit this behavior include, but are not limited to:
    • PDF Import
    • Plot/Print/Publish
    • Colors (Options > Drafting tab > AutoSnap settings)
    • Select Color
    • From Template
    • XREF (External Reference)
  • For example, when trying to import a PDF in AutoCAD with PDF Import, after selecting the file, the next dialog is not shown. You would normally see this window:
PDF import options dialog window
 
 

Causes:

General causes

  • Changes in screen resolution
  • Changes in the number of monitors connected to the computer
  • Third-party interfering with dialog windows

AutoCAD causes

  • AutoCAD's variables changed to nondefault values
  • Corrupted user profile
Notes
  • Most programs maintain the last positions of their dialog windows, expressed in X/Y coordinates for the monitor. A window might come up off-screen if it was last positioned at a point that is no longer viewable. For example, when an application is opened on a monitor with different resolution settings or with a dialog that was positioned on a secondary monitor that has been disconnected from the system.
  • The program continues to put the dialog box at the last-known X/Y position on a no-longer-present monitor.
  • Pressing the Esc key is equivalent to clicking the Cancel button in the window, which restores control of the program.
  • The "ding" sound is the default Windows alert when you try to click outside a modal dialog.

Solution:

Do one of the following:
  • Move the window to a different monitor. Hold down the WINDOWS + SHIFT keys and then press the LEFT or RIGHT ARROW key on the keyboard. This moves windows between screens and will pop the missing dialog into view. 
  • Use the keyboard to move the window into view. Try this first on a visible window to see how it works:
    1. Execute the command to activate the dialog window.
    2. Press ALT + SPACEBAR on the keyboard.
    3. Press the M key and tap any ARROW keys.
    4. Move the mouse to bring the window into view.
    5. Click the left mouse button to cancel the operation.
  • Change the screen resolution to a different value, smaller or larger. This should bring all dialog windows back into view. Move the dialog window in question to center screen (or toward the upper left) and then exit the program before changing the screen resolution back to what it was.
  • With multiple displays, press WINDOWS + P and then choose PC screen only. Adjust the dialog window to center screen and then exit the program before setting the display back to Extend.
Secondary monitor different project options
  • When working with multiple monitor configurations, it can happen that the window is opened on a screen that is not connected to the computer at the moment. Try these methods to get the window back on screen:
    1. Right-click the windows taskbar and select "cascade windows".
    2. Disconnect all but one attached display while window is still running. All windows should then appear on the still attached display. Then reconnect the other displays.
  • Disable unused video ports in the system's video settings or video driver control panel. A dialog window could be moving to the video space of an unused video port (even if a second monitor has never been connected to it).
  • When working with multiple monitors, ensure all connected display devices (external monitors and laptop monitors) are set with consistent display scale and resolution in Windows Settings > System > Display Settings
  • Right click on AutoCAD shortcut icon > Properties > Compatibility > Change high DPI settings > Check 'Override high DPI scaling behavior' and select 'System' from drop-down list.
  • Test the issue with a different Windows user. If the other user account works then Reset the Windows Profile.
Note: Before doing this, check the points following first.
  • Hold the Windows key (usually between the left Ctrl and Alt key) and press the left or right arrow key a number of times. This will cycle the location of the window between the edges of each monitor. If this has no effect, hold down the Windows and Shift keys and then press the left or right arrow keys on the keyboard. This moves a window from one monitor to another and may pop the missing dialog box into view.

AutoCAD-specific causes

  • Be sure that the FILEDIA and CMDDIA variables are each set to a value of 1. Type them in on the command line (separately) to check their current value, and set to 1, if necessary.
  • Reset AutoCAD to defaults: How to reset AutoCAD to defaults.
  • If this does not resolve the issue, fully uninstall and reinstall the affected Autodesk product: Clean uninstall of AutoCAD or verticals

Products:

AutoCAD Products;


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