"Disk full while accessing" or "…not enough space" and storage, operation related messages appear in Revit

Autodesk Support

Mar 12, 2025


Products and versions covered


Issue:

One or more of the following messages are displayed when opening, saving, or syncing a model in Revit:

  • Revit

Disk full while accessing
<Path>

Disk full while accessing message in Revit

  • Revit

There is not enough space on drive C: to create the temporary files that Revit needs. Either free up space on this drive or redefine Windows user variable TMP to be a folder on another drive with more space.

There is not enough space on drive C:\ message in Revit

  • Open Model

This operation could not be completed. Please try again.

This operation could not be completed message in Revit

The Revit journal records lines like the following preceding the error:

0:< openDocumentFileForUI: Insufficient disk space to create the temporary files that Revit needs. 
0:< Unhandled exception - exception: Autodesk.Revit.Exceptions.InsufficientResourcesException, msg: Insufficient disk space to create the temporary files that Revit needs.

Causes:

There is not enough space on the disc drive to work with models in Revit.

Solution:

Free up storage space

Work with your IT/computer support to free up space on the system. Check the space on the specific profile as well.

Windows files that can be deleted:

See the following link for a Windows tool to clear space on the system: Disk cleanup in Windows

Revit specific files that can be deleted

Journal files: When saving non-workshared Revit files on a network drive, Revit creates copies of these files in the Journal directory. Delete these extra files to save some disk space: Location of Revit journal files

Best practices to spare disk space for Revit cloud models

  • In Revit 2024 (and later releases): You can switch the location of the Collaboration Cache folder. This could be helpful if your C: drive tends to run full.
  • CollaborationCache files: Delete the files in CollaborationCache folder: C:\Users\%USERNAME%\AppData\Local\Autodesk\Revit\Autodesk Revit 20xx\CollaborationCache

  • PacCache files: Delete the files in the PacCache folder: C:\Users\%USERNAME%\AppData\Local\Autodesk\Revit\PacCache. 

Note: Logs folder cannot be deleted.

Note: Revit cloud models will be slow to open the first time once the cache is rebuilt.

Secondary Drive

If you have a secondary drive (like a D:\ drive), the following article has some additional options like redirecting the Temp folder to the secondary drive: "You are out of disk space" when installing an Autodesk product on Non-C drive

Optimize model size

See the following article for information on How to keep the size of Revit files manageable.

Additional Articles

For more articles on the operation could not be completed error, see the following link: "This operation could not be completed." when opening cloud model in Revit.

Products:

Revit Product Family; Revit Cloud Worksharing;


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