Does Autodesk support third-party backup software for Vault?

Autodesk Support

Aug 16, 2024


Products and versions covered


Issue:

  • Autodesk publishes information on the components that need to be backed up for a full recovery of all the important components of a Vault are restoring correctly in a disaster scenario.
  • Does Autodesk support third-party backup software?
  • Do 3rd party backup tools cause duplicate backups to be created?

Causes:

  • Backup policy considerations
  • Cloud storage cost issues when multiple backups are created

Solution:

Autodesk does not support any third-party software or methods to backup Vaulted data. The ADMS (Autodesk Data Management Server) Consoles Backup and Restore wizard is Autodesk's supported disaster recovery solution for Vaulted data.

Some customers with larger data sets choose not to use the Vault Server backup solution to backup their Vaulted data. The reasons for this can vary. They can include but are not limited to the following:
  • Some consider the safeguards built into it, such as file validation, take so long and impact productivity.
  • They are not aware of Vault Professional's increased backup functionality, namely incremental or hot backups.
  • They are not willing or able to increase investment in Autodesk Vault by purchasing Professional licenses.
  • They have not yet developed trust in the backup solution.
  • Company policy dictates a standard backup procedure.
When Vault administrators choose to use an alternative disaster recovery method or tool not supported by Autodesk, they accept complete responsibility for the successful recovery of their Vault data following a disaster. In that scenario, they might need to know what components of the Vault they need to consider. For this reason, Autodesk has published a white paper to maximize the chances of a successful restore in case of a disaster. The document is published by Autodesk to help Vault Administrators avoid a disaster by backing up what is needed. Autodesk does not document how to configure third-party solutions.

If a 3rd party solution is used check that it supports backing up SQL server and files since most do not backup SQL data by default. If workgroup replication is used confirm the 3rd party tool supports SQL transactional replication.

Autodesk will help any customer in a disaster recovery situation to restore their Vault data. However, if the data is corrupt or incomplete, success is not guaranteed. The backup solution that comes with Vault Server offers the best chance of successfully recovering from any disaster.

Examples of unsupported third-party backup software:
  • Dell AppAssure
  • Veeam
  • Backup Exec
  • Symantec Backup Exec
  • Volume Snapshot Service (VSS)
  • Virtual Machine snapshots
  • Virtual machine image level backups
  • Only file backups

Products:

Vault Basic; Vault Professional; Vault Workgroup;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support