Unable to launch Dynamo Player in Revit

Autodesk Support

Feb 6, 2024


Products and versions covered


Issue:

Revit Dynamo Player crashes on startup when running on a company network. Right after the failing attempt to start the application, the Dynamo player button in Revit gets greyed out.

Additionally:
  • The process "nwjs" is missing in Windows Task Manager, but Revit can run Dynamo scripts without the Player.
  • This issue is present on all machines in the company's network environment, but not when taking an affected machine to a home office environment and using it with a borrowed license.

Environment:

ZScaler 

Causes:

Dynamo needs to establish a connection with some ports that are being blocked by Zscaler (or other Network Security Services/ Programs).

Solution:

Consult with your local IT Support on enabling the following ports for Dynamo processes to use: 
  • Make sure to enable the following port to get opened by the Dynamo Player: 2.19.11.225
  • Port 8000 for communication between application and server.
  • The RestDynamoCore processes are started on free ports beginning at 5000. It is recommended to unblock ports from 5000 to 5050 if possible.

Products:

Revit; Dynamo;


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