"An error occurred while communicating with the cloud worksharing service" when opening certain cloud models in Revit

Autodesk Support

Mar 15, 2025


Products and versions covered


Issue:

When trying to open a cloud model in Revit, the following message displays:

Communication Error

An error occurred while communicating with the cloud worksharing service.


Image of communication error

The model cannot be opened, synchronized, or saved.

 

Causes:

  • Corruption in the local cache folder data of affected one user or users.

  • Composite or corrupt link.

  • Corruption in the host model.

Solution:

Check Affected Models

If this message is displayed for all cloud models, see the following article for troubleshooting this behavior: "An error occurred while communicating with the cloud worksharing service" appears when opening a Cloud model in Revit.

Check for Composite Model

  1. Turn off all worksets when opening the model. See the following article for information on How to turn off worksets when opening Revit models
  2. If the model opens, use Unload for me option to unload all Revit links.
  3. Open all the worksets.
  4. Reload the Revit links, to see if there is an error with one or more of the links.
  5. If an error is encountered with links, access the cloud project through a browser, and download the link.
  6. If the link is downloaded as a ZIP file (instead of a Revit file), see the following article for handling the composite model state: "Failed to open document" when working with Revit cloud model containing Desktop Connector links.

Audit host/links

  1. Open the host model and the linked files with Audit.

    1. Make sure that there are no circular references within the project (file A is linked to file B and file B is linked to file A). Link files as 'Overlay' instead of 'Attachment'.

  2. Synchronize the changes back to central and close files.

  3. Reopen the host model.

Note: It is advised to Audit Revit models regularly (the frequency needed can depend on the rate of change, but general guidance is weekly).

Image of open option window with audit checked

Download Model

If Auditing the model doesn't help, download the affected model from the cloud. Once the download is done, try to open it (with audit) locally and see if any other warnings appear.

Clear Cache

If the downloaded model opens fine, but the cloud model still won't open, with (or without) Audit selected, try clearing the Collaboration Cache and PacCache for the affected model.  See How to clear a corrupt/damaged cloud worksharing model or outdated link from the system in Revit.

 

Products:

Revit Product Family; Revit Cloud Worksharing; BIM 360; Construction Cloud;


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