"Data in file (file name).rvt is corrupt and needs to be manually recovered" when opening a file or syncing a file to central in Revit

Autodesk Support

Feb 1, 2025


Products and versions covered


Issue:

When opening a file or syncing a file to central in Revit, the one (or more) of the following messages is displayed:
 

TextScreenshot

Revit File Corrupted

Data in file (file name) is corrupt and needs to be manually recovered.
Data in file (filename).rvt is corrupt and needs to be manually recovered

Revit

Data corruption in file (Filename).rvt.
data corruption

Revit

Data in file an unnamed file is corrupt and needs to be manually recovered.
Revit file corruption message

 

Other messages that can occur related to corruption:

 
 
 
 

Causes:

For information on possible causes of corruption in Revit, see: Causes of data corruption in Revit.

Solution:

Initial Troubleshooting

  • Audit: If not already done, try opening the model using the Audit checkbox.
Note: If this message only occurs when the Audit box is checked, a different issue may be occurring go through the troubleshooting in the article: Cannot open file with audit in Revit.
  • Check available storage: See the following article for items to check for Revit corruption errors related to system storage (such as low disk space).
  • Check for Corrupt RVT links: When Revit opens a model, it accesses linked Revit models to check for changes that have occurred. If the linked model is corrupt, a corruption message can appear during the open process (even though the model is not itself corrupt).

To check for this:

  • Non-Workshared models: Move/copy the model to location that does not have access to the links (generally moving/copying it to another folder works, unless the link is in a network location).
  • Workshared models: See the following article for information on How to turn off worksets when opening Revit models. If the model opens without error when all worksets are closed, start opening the worksets and see if the error returns when accessing a workset containing Revit links.

Cloud Models

If this error is occurring for cloud based Revit models, see the following article for troubleshooting options:

"Data in file [name] is corrupt and needs to be manually recovered." when opening cloud model in Revit

Local Models

  • Recover Automatic Backup: If the initial troubleshooting does not lead to a solution, see the following article for information on How to recover Revit model backup.
    • Cleanup repaired model: If a good backup file can be recovered/opened, go through the following steps to clean up the model/system:
    1. In the Open dialog box, check the Audit and Detach from Central checkbox.
    2. Go to Manage > Purge Unused.
    3. Go to the Application Menu > Save As dialog box, and save the file under a new name (in the same location as the original central model).
    4. Switch to the desktop and open Windows Explorer (Windows key + E).Type %TEMP% in the address bar.
    5. Delete as many files as possible from this folder. Some files may not be able to be deleted if they are in use by other applications.
    6. Move the old local files and their backups to the desktop.
    7. Open Revit.
    8. Open the project file with "Create new local" checked.
  • Recover manual backup: If all of the local files are corrupt and all of the automatic backups are corrupt, recover a manual backup created outside of Revit.

 

Other items to check

  • Non-workshared models saved directly to a network path will have a copy saved in the journals folder.
  • Non-workshared models stored on a cloud drive (e.g., A360 Drive, Dropbox, Box) may have separate backups--check the web interface for the cloud service for backup recovery options.

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support