"Failed to open document" when working with Revit cloud model containing Desktop Connector links

Autodesk Support

Jan 13, 2025


Products and versions covered


Issue:

The following error message is received when adding Revit links through Desktop Connector, reloading links, synchronizing, opening worksets containing links, or using "Load as Group" in Revit:

Revit

Failed to open document.

Failed to open document. error in Revit

Journal

The following entries can be seen in the Revit journal file
' [Jrn.ModelOperation] Rvt.Attr.Scenario: ModelOpen COMMON.OS_VERSION:  Rvt.Attr.ModelVerEpisode: 00000000-0000-0000-0000-000000000000 -1 , Rvt.Attr.ModelPath: RVT[4895415424942081189] Rvt.Attr.ModelSize: 0 Rvt.Attr.DetectDuration: -1 Rvt.Attr.Worksharing: UnknownWorksharingState Rvt.Attr.ModelState: InvalidOleStructure Rvt.Attr.DiskType:  
5:< Load exception "COleException", code=0x80004005: Unspecified error 
5:< COleServerDoc::ReportSaveLoadException 
' 5:< TaskDialog "Failed to open document."

Causes:

One of the following:
  • The Revit Model contains links.
  • The latest version of one of the links has not been published.
  • The Desktop Connector sees the composite file as a ZIP instead of an RVT.

Solution:

See the following article for troubleshooting this behavior: Revit Journal records "COleException", code=0x80004005: Unspecified error

Autodesk Docs Project

If the cloud project is hosted on Autodesk Docs (and not BIM 360 Document Management) and the version of Revit used is 2023.1 or later, consider Bridging the model and linking through External Resource (instead of the Desktop Connector).

More Troubleshooting

If journal entries like the ones listed in the Issue section are not showing up on your system, check if one of the following articles applies:
Journal EntriesArticle
Collaborate.dll is not signed and cannot be an internal add-on"Failed to open document" when opening a cloud workshared model in Revit
Load exception "COleException", code=0x80030109: The docfile has been corrupted."Failed to open document" error when linking cloud model via Desktop Connector to a Revit model

If these articles don't apply, check this link for more articles on this error: "Failed to open document"

Products:

Revit Product Family; Revit Cloud Worksharing; BIM 360; Construction Cloud; Desktop Connector;


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