Error: “FileLink.dlu failed to initialize properly” after installing 3ds Max 2017.1 Update 1

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

After installing Update 1 for 3ds Max 2017.1 and launching 3ds Max, an error message appears: “DLL <C:\Program Files\Autodesk\3ds Max 2017\stdplugs\FileLink.dlu> failed to initialize properly – not loading.”  After clicking OK, the error message “3ds Max failed to start” may appear and then the program closes.

filelink.jpg

failed.jpg

Causes:

The 3ds max Plugin.UserSettings.ini file may contain folder paths which point to folders that may no longer exist on the local PC. For example, the Plugin.UserSettings.ini file may contain a reference to an Nvidia folder which isn’t present on the machine unless mental ray has been installed for 3ds Max 2017.1.

 

Solution:

  1. Navigate to the following folder: C:\Users\%username%\AppData\Local\Autodesk\3dsMax\2017 - 64bit\ENU
  2. Open the Plugin.UserSettings.ini in a text editor, such as Notepad.
  3. Click File > Save As and resave the file with the name Plugin.UserSettings.ini.BAK to make a backup copy.
  4. Now, verify that each of the paths listed in the .ini file exist on the PC, even if the contents of those folders are empty. If necessary, delete the line Additional MAX plug-ins NVIDIA=C:\Program Files\Autodesk\3ds Max 2017\PlugIns\NVIDIA\Plugins\ if this folder path doesn’t exist on your system.
  5. Click File > Save As and resave the file with the original name Plugin.UserSettings.ini.
  6. In addition, check the plugin.ini files in the C:\Program Files\3ds Max 2017 folder, and the one in the relevant 3ds Max 2017 root "language" folder, such as en-US\.
  7. Open both plugin.ini files in Windows Notepad and check the plugin path listings. If necessary, highlight and copy (from each line, one at a time) the directory path, past the = sign.
  8. Open a Windows Explorer window, then paste the copied line into the top of the Windows Explorer Search field to navigate to that location.
  9. If the folder does not exist on the drive, remove that entire line from the plugin.ini file.
  10. Continue until you have checked every line of both plugin.ini files, then re-save both plugin.ini files back to their original locations.
  11. Quit Notepad and try launching 3ds Max 2017.1 again.

Products:

3ds Max;

Versions:

2017;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support