"Licensing System Error 2" when launching Revit

Autodesk Support

Oct 11, 2024


Products and versions covered


Issue:

When launching Revit, the below error appears:

Autodesk Revit 201x

Licensing System Error 2

Licensing System Error 2

 

Causes:

  • Corrupted C++ files.
  • Missing updates for Autodesk Licensing Service and Single Sign On components.
  • Corrupted LoginState.xml.
  • Security software blockage.

Solution:

Solution 1:

In order to solve the issue, follow these steps:

  1. Close all Autodesk applications.
  2. Open Task Manager > Details tab.
  3. Close the below processes, if any:
    • AdAppMgrSvc.exe
    • AdSSO.exe
    • AutodeskDesktopApp.exe
    • ADPClientService.exe
  4. Go to C:\Users\<user>\AppData\Local\Autodesk.
  5. Delete the folder Web Services (contains the LoginState.xml file).
  6. Sign into Autodesk Account.
  7. Download and install all the applicable updates for your version of Revit:
  8. Launch Revit.

Solution 2:

Solution 3:

Solution 4:

Verify the following:

  • If using the antivirus "Trend Micro", sign in into the Trend Micro Web Portal, and then Devices -> Configure Policy -> Behavior Monitoring -> Approved Program List and add "Revit.exe."
  • If using McAffee firewall or any type of firewall or antivirus in the environment, try disabling it and reinstall Revit.

Solution 5:

Reset License by deleting the following files or folders. 
  • C:\ProgramData\Autodesk\CLM\LGS\ProductKey_ProductVersion.0.0.F\LGS.data
For example, in AutoCAD 2019, the file may be here: C:\ProgramData\Autodesk\CLM\LGS\001K1_2019.0.0.F\LGS.data
  • C:\ProgramData\Autodesk\ADUT
  • C:\Users\user\AppData\Roaming\Autodesk\ADUT (if it exists)
  • C:\Users\user\AppData\local\Autodesk\Web Services\LoginState.xml

Products:

AutoCAD Products; Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support