"This operation could not be completed..." when saving or synchronizing central model to Revit Server

Autodesk Support

Jan 3, 2025


Products and versions covered


Issue:

  • When saving or synchronizing the central model to Revit Server the following message appears:

Operation Could Not Be Completed

This operation could not be completed. Please
try again.

If you are collaborating on a model using the cloud or Revit
Server, check your network connection.

If the problem persists, save any changes to the models
locally.

Screenshot of the error message.
 

  • The following lines are found within the ModelService.log:
[Date] [Time] ERROR TID(33) LOGGER(Autodesk.Social.Services.Files.FilesImplementation)
MSG(BlockError: System.UnauthorizedAccessException: Access to the path '[Path]' is denied

  • An entry like the ones below may be recorded in the Revit journal:
System.ServiceModel.FaultException`1[Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault]: Access to the path 'D:\Revit2022\TempRepository' is denied.
DBG_WARN: element ######## does not have PartitionId assigned: line 926 of Partitions\PartitionTable.cpp.
 

Causes:

This may be one of the following:

  • Permissions are improperly set for Revit Server.
  • One of the model elements is corrupted.
  • Not all prerequisites according to the guidelines are installed on the local server.

Solution:

To resolve this issue, follow these steps:

    Folder Permissions

    • Ensure that full control is set for the System, Administrators, Creator Owner, and Network Service accounts. The permissions needed are described in the following help topics:

    Note: If the Revit Server data is stored on a remote system, additional steps must be taken, see Step 7 in the help topic above, to configure a domain administrative account for use with Revit Server): Installing Different Versions of Revit Server on the Same Machine.

    • Check if the permissions appear to be set correctly for the folder in question:
    1. Create the folder (if it does not already exist) and re-test.
    2. Right-click on the folder and select Properties.
    3. Click Security.

    Note: If Everyone group is displayed skip to step 8.

    1. Click Edit.
    2. Click Add.
    3. For the account type Everyone, then Check Names.
    4. Once the account shows up underlined (indicating the name check was successful), click OK.
    5. Select the new Everyone Group.
    6. Click to put a check in the Allow checkbox to set Full control.

    Screenshot of the folder permissions.

    1. Click OK.
    2. Try saving the model to the server again.

     

    Check journal for corrupt elements

    Go through the steps in the following article to check if the Unexpected behavior in Revit due to elements with no workset assigned

    Revit Server Prerequisites

    Ensure that the Revit Server Prerequisites are installed according to the Windows Server installed:

    Additional Articles

    For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

    Products:

    Revit Product Family;


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