"Revit has stopped working" and then Revit shuts down

Autodesk Support

Sep 11, 2024


Products and versions covered


Issue:

When launching or working in Revit the message "Revit has stopped working" is displayed and then Revit shuts down.
 
One or more of the following lines are found in the journal file recorded by Revit prior to the program closing:
  • DBG_WARN: failed to open message_queue named 'Session#####_P0MasterQueue' because The system cannot find the file specified.: line 203 of NOBLE\ManageWorkerServices.cpp
  • DBG_WARN: failed to create message_queue named 'Session####_P0MasterQueue' because boost::interprocess_exception::library_error: line 203 of NOBLE\ManageWorkerServices.cpp
  • DBG_WARN: failed to create message_queue named 'Session####_P0MasterQueue' because The system cannot find the path specified.: line 202 of NOBLE\ManageWorkerServices.cpp

Causes:

Missing or incorrect registry key.
 

Solution:

Modify "Shell Folders" Registry key

Set the correct value for the affected registry key by going through the following steps:

IMPORTANT: Problems caused by improperly editing the Windows registry could render your computer operating system unusable. For more information please read the information in the See Also section below.

Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft Knowledge Base at http://support.microsoft.com.

Use the Microsoft® Registry Editor only at your own risk and only after backing up the registry as well as the system.dat and user.dat files as outlined for your operating system in the Microsoft Knowledge Base and in the related solution, TS66513. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.

  1. Run REGEDIT from the Start menu and then browse to the following key:
HKEY_LOCAL_MACHINE->Software->Microsoft->Windows->CurrentVersion->Explorer->Shell Folders
  1. Verify that the following key exists (within Shell Folders): Common AppData
    • If the key does not exist create it (Right click -> New -> String Value)
    • If the key exists (including having just created it from the step above) verify it contains the following Data (Right Click Modify): C:\ProgramData                          User-added image
  2. After making changes in the registry, reboot the system and retest

Alternatively: 

  1. You can create a *.txt file in Notepad with the following information: 
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]
    "Common AppData"="C:\\ProgramData"
  2. Save the *.txt file and change its extension to *.reg
  3. With your new *.reg file created you can just double click on that to update your registry key with the related information
You can find such a *.reg file created in the ZIP folder attached to this article. Feel free to download it and use it to correct the above described behavior.

Run as Administrator

If the registry key is properly configured, but you are still encountering this issue (with the Revit worker journal showing DBG_WARN: failed to open/create message_queue named 'Session…), go through the following steps:

  1. Restart the system.
  2. Check that the following folder exists (there should be nothing in this folder, as there would be no sessions of Revit open after the restart):
    Revit 2024 and later: C:\ProgramData\boost_interprocess
    Revit 2023 and earlier: C:\ProgramData\RevitInterProcess
  3. If you find any files in the path above, move them to another location (e.g. to your Desktop).
  4. If the folder above does not exist, try starting Revit as an administrator and retest (Right click -> Run as Administrator), otherwise restart Revit normally and retest.

More Troubleshooting

If the information above does not lead to a solution, see the following article with more information on other causes for crashes: Troubleshooting Revit crashes

See Also:

 

 

 

Products:

Revit Product Family;


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