"Revit failed to start" or "RevitWorker.exe was not found." when launching Revit products

Autodesk Support

Feb 20, 2025


Products and versions covered


Issue:

Users reported that Revit fails to start and one of the following messages appears:
 

Revit initialization failure

Revit failed to start

Please click "Learn More" below to diagnose and correct the issue.
 

Revit failed to start

Lines similar to the following are written in the Revit journal file:

DBG_WARN: Failed to launch Worker: line 203 of E:\Ship\2024_px64\Source\Revit\RevitDB\Managers\MultiProcessImpl.cpp. 
Failed to create worker 1 

 

RevitWorker.exe was not found.

Revit cannot restart because it is missing a component. You must reinstall the application.
 

RevitWorker.exe was not found

Revit / Revit LT may crash with a CER error report before the software start screen appears. 

The Revit journal file records lines similar to the following: 

' 1:< DBG_WARN: failed to create message_queue named 'Session1764_P0MasterQueue' because boost::interprocess::intermodule_singleton initialization failed: line 202 of NOBLE\ManageWorkerServices.cpp.
' 1:< DBG_WARN: Could not establish Worker Services!: line 140 of NOBLE\ManageWorkerServices.cpp.
'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging finished virtualization services 
'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging finished worker services 
'C DD-MMM-YYYY HH:MM:SS.SSS;   1:< logging erased queues 
' 0:< TaskDialog "RevitWorker.exe was not found."

Causes:

  • Third party software "Cybereason" (Cybersecurity Software) blocks the RevitWorker process.

  • RevitWorker.exe set to “Run this program as an administrator”.

  • Windows issues: 

    • Pending/Missing/Corrupter Windows Update.

    • Permission rights.

    • Corrupted Windows Management Instrumentation Service (WMI).

Solution:

Cybereason

  1. If Cybereason software is running on the system, try temporarily disabling this.

  2. If the error is cleared when disabling, check for updates to the software and work with Cybereason support to prevent it from interacting with the RevitWorker process.


RevitWorker.exe is running as an Administrator

Check if RevitWorker is running as an Administrator. If the RevitWorker process is run as an administrator while the Revit process is not, then Revit will not be able to communicate with the RevitWorker properly. Test if this is happening by going through the following steps:

  1. Right-click the Revit icon (from the Desktop or Windows Start menu).
  2. Select Run as Administrator.
Screen showing how to start Revit in admin mode
 
Note: If you don't have the administrative rights to run Revit as an administrator, work with your computer/operating system support to perform this test. Do not permanently change the "Run this program as an administrator" setting in Revit.exe properties because this affects network drive access (See Mapped network drives are unavailable in Autodesk products).
  1. If the error is cleared, RevitWorker is running as admin.

 

Fix RevitWorker

If confirmed that RevitWorker is running as admin, go through the following steps to change this:

  1. Go to the Revit installation directory (by default C:\Program Files\Autodesk\Revit ####).

  2. Right-click the RevitWorker.exe file and select "Properties".

  3. Select the "Compatibility" tab.

  4. Clear both the "Compatibility mode" and "Run this program as an administrator".

Screen showing RevitWorker.exe properties to unselect

  1. Select Apply and then OK.
  2. Start Revit normally (without using "Run as Administrator").


Windows issues

Problems with the Windows setup/configuration can lead to this behavior.
Check with your computer/operating system support on the following topics:

  • System Information "Can't Collect Information":
Go through the following steps to check if this issue is occurring:
  1. Click Windows Start.

  2. Type "msinfo32.exe"

  3. Click System Information (App).

  4. Check if System Information shows "Can't Collect Information" as shown in the following picture.

Screen of System Information window

 

Check Windows Management Instrumentation service

  1. Open the Windows Services by typing "services" on the Windows Start.

  2. Check for the service Windows Management Instrumentation and stop it.

  3. Open Notepad (Start -> Run -> Notepad) or another text editor.

  4. Add the following text (copy/paste): 

@echo on
cd /d c:\temp
if not exist %windir%\system32\wbem goto TryInstall
cd /d %windir%\system32\wbem
net stop winmgmt
winmgmt /kill
if exist Rep_bak rd Rep_bak /s /q
rename Repository Rep_bak
for %%i in (*.dll) do RegSvr32 -s %%i
for %%i in (*.exe) do call :FixSrv %%i
for %%i in (*.mof,*.mfl) do Mofcomp %%i
net start winmgmt
goto End

:FixSrv
if /I (%1) == (wbemcntl.exe) goto SkipSrv
if /I (%1) == (wbemtest.exe) goto SkipSrv
if /I (%1) == (mofcomp.exe) goto SkipSrv
%1 /Regserver
:SkipSrv
goto End
:TryInstall
if not exist wmicore.exe goto End
wmicore /s
net start winmgmt
:End
  1. Save the document with the name "WBEM_Fix.bat" in the folder C:\Autodesk (the location can be changed but avoid the Desktop or user folders).

  2. Right-click the BAT file and select Run as administrator.

  3. A Command prompt will appear and will perform several steps. Let the process run until it closes automatically.

  4. Start Revit again.

Note: If the batch script doesn't clear the error, work with your computer/operating system support to resolve this Windows issue.

  1. Open a Windows Command prompt as an Administrator.

  2. Run the following two commands:

    • c:\windows\system32\wbem\Mofcomp.exe c:\windows\system32\wbem\cimwin32.mof

    • c:\windows\system32\wbem\Mofcomp.exe c:\windows\system32\wbem\en-US\cimwin32.mfl


Other Troubleshooting

See the following article for troubleshooting on a similar issue (different symptoms and similar journal entries): "Revit has stopped working" and then Revit shuts down"

 

Products:

Revit; Revit LT;


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