"This operation could not be completed. Please try again" when trying to open or save files to a new Revit Server

Autodesk Support

Jan 3, 2025


Products and versions covered


Issue:

When attempting to access a newly configured Revit Server, the open or save file dialog boxes show the following error and the server is unable to be accessed:

Operation Could Not Be Completed

This operation could not be completed. Please try again. 
If you are collaborating on a model using the cloud or Revit Server, check your network connection. 
If the problem persists, save any changes to the models locally. 

This operation could not be completed. Please try again when attempting to open files from Revit Server

The Journal file from Revit will show the following:
' 0:< System.ServiceModel.FaultException`1[Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault]: System.ServiceModel.FaultException`1[Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault]: This Revit Server is not a host (Fault Detail is equal to Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault). 

0:< WCF Generic Fault Exception. The services could not be in a good state. Please contact technical support. 

' 0:< 1 ModelServerState "Created": Current server = "<Not Determined>", Model server = "", Model server state = "Internal Error" 
' 0:< 1 ModelServerState "Created": Current server = "<Not Determined>", Model server = "", Model server state = "Internal Error" 
' 0:< 0 ModelServerState "Destroyed": Current server = "<Not Determined>", Model server = "", Model server state = "Internal Error" 

Causes:

The new Revit Server does not have the host role enabled. 

Solution:

To resolve this issue, enable the host role for the newly setup Revit Server: Change the Role for an Instance of Revit Server.

Additional Articles

For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support