Performance, crash, failed open, sync issues when working in Revit

Autodesk Support

Feb 6, 2025


Products and versions covered


Issue:

Operations interacting with materials are significantly slow or lead to a hang-up/ stop at a specific stage in Revit models. This would include (but not be limited to):
  • Opening the Materials dialog box.
  • Opening the Purge Unused Command takes a long time or cannot be completed, Revit is frozen.
  • Synchronizing with a central file, especially when multiple project members are working in the central file.
  • Synchronization is frozen at a specific point, for example, 'Reload latest', or at a specific stage, for example, 30% or 60%.
  • The syncing issues usually appear after a family is loaded into a project or after a family is edited.
  • The syncing issues may appear mostly when more members are working on the project.
  • Slow performance while loading families to specific projects/ project templates. 
  • General instability issues, crashes that can result corrupt files.
  • Sometimes unable to open the file with a serious error displayed.
  • Slow performance while interacting with a specific project when other projects in the same environment work as expected.
  • Thousands of default materials keep reappearing even after using the 'Purge Unused' command.

Causes:

  • THIS MACRO HAS BEEN CREATED FOR THIS SPECIFIC ISSUE, AND IF YOU DO NOT SEE A LARGE NUMBER OF MATERIALS SHARING AN ASSET, DO NOT INSTALL THIS MACRO.
  • To verify the issue, go to Manage > Materials > Standard and click the Appearance Tab (or Aussehen in German) to see how many materials share the Standard Asset.
Material Browser

Solution:

New Solution for Revit 2022 and higher versions: Add-on:

To determine  if any duplicated materials exist in Revit models, install the Duplicated Materials Add-on for Autodesk® Revit® from Autodesk App Store. Identify and remove easily the multiplied instances with the help of this tool

Note: this tool won’t remove such duplicated materials that are actively used in the model.

Installation:

  1. Download the app/plug-in from the Autodesk App Store.
  2. Close all Revit.
  3. Double-click the downloaded installer to install the app/plugin.
  4. Restart Revit.

Usage:

  1. Launch Revit and navigate to the Add-Ins tab in the ribbon.
  2. Select the RevitMaterialScanner command from Add-ins/ External Tools menu.


See here more instructions for installation and usage and a video guide.

Alternative, old solution: Install/Run Macro

If you are not able to use the Add-on, an alternate (older) option would be to install and run the following macro.

  1. Close Revit.
  2. Extract the ZIP file: It will contain a DeleteStandardMaterials folder with two subfolders (add-on + Source).
  3. Copy the add-on + Source folders to the following path: C:\ProgramData\Autodesk\Revit\Macros\####\Revit\AppHookup\DeleteStandardMaterials
  4. Start Revit.
  5. Open the file in question.
  6. Open Manage > Macro Manager > Application tab.
  7. The macro should show up in the Macro manager as “DeleteStandardMaterials”.
DeleteStandardMaterials Macro
Note: Make sure that the Macro reads “DeleteStandardMaterials” and nothing else. If it reads something else, delete the file as start over as the macro can delete a significant amount of data.
  1. Select one by one "DeleteAppearanceAssetWithName", "DeleteMaterialWithName", "DelteThermalAndPhysicalAssetWithName" and start the command "Run".
  2. A further dialog will appear where it can be defined how many instances should be deleted once. Choose no more than 3000 instances at once if you run the Macro on a cloud model. In the cloud there is a limit of around 3000 instances that can be deleted at the same time. After this, repeat this action until all the multiplied materials are deleted.
Number of materials to delete
  1. After the macro has finished processing, save the model.
  2. Confirm that the performance issue has been resolved.
Note: After cleaning the project with macro, load Families only from trusted libraries.
Note: Before running the macro make sure that the Macros are enabled in Revit. Check the Macro related setting in "File Menu/ options/ Macros": Help | Options Dialog: Macros Tab | Autodesk

 

    Cloud Models

    If working with cloud models, check that the model syncs normally after running macro. If there are errors, see the following article: Sync fails after cleaning duplicated materials or assets in Revit
     

    Products:

    Revit Product Family;


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