Fusion crashes when launching the Tool Library

Autodesk Support

Jul 5, 2024


Products and versions covered


Issue:

Users reported that Fusion crashes and generates a crash report when attempting to open the Tool Library from the ribbon in the Manufacture workspace:
  • Opening the Tool Library while editing a toolpath may be successful.
  • Certain Libraries may appear empty when opening the Tool Library via a toolpath.

Causes:

This could be caused by one of the following:
  • Out of date graphics driver.
  • Lacking permissions to %appdata%\Autodesk\Autodesk Fusion 360 directory containing the tool libraries.
  • A corrupted library.
  • Multiple monitors.

Solution:

Work through the following suggestions:

Reset / Repair Fusion 

  1. Reset Fusion from Fusion 360 Service Utility
  2. Repair Fusion from Fusion 360 Service Utility.

Remove xml files

Remove the xml files in %LOCALAPPDATA%\Fusion 360 CAM\Settings.

Check the graphics card / drivers

Check for a corrupted Library

Crashes and hangs on entering the tool library can be related to specific tool libraries:
  • Removing all of the tool libraries can help identify if a corrupted library is the problem.
  • Removing / returning the tool libraries one by one can help identify which particular library is corrupted.
Cloud libraries can be removed through the Assets folders in the team / personal hub. Local libraries can be removed from the following file paths:
  • macOS: ~/Users/<USERNAME>/Library/Application Support/Autodesk/CAM360/libraries/Local
  • Windows OS: C:\Users\<USERNAME>\AppData\Roaming\Autodesk\CAM360\libraries\Local
Note: Always create a back up of libraries before deleting them. Send copies of libraries that appear to be causing crashes to the Fusion 360 Support team on the Fusion Support Forum.

Fusion is unresponsive after launching the Tool Library

Sometimes, Fusion will not crash but will hang and appear unresponsive when launching the Tool Library. In this case, the Tool Library is likely being drawn in a hidden location. Using the techniques in the following article should help find and move the Tool Library window back to its intended location. See: Parameter or other dialog is missing in Fusion 360.

Multiple Monitors

Unplug external monitor before launching Fusion 360. Then if reconnect it if desired. 

Products:

Fusion;


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