"HTTP Error 404.0 - Not Found" when trying to access a Vault Thin Client 2022 and newer

Autodesk Support

Jan 13, 2025


Products and versions covered


Issue:

When trying to access a Vault Thin Client 2022 (to access a specific Vault database) following error message is presented:


HTTP Error 404.0 - Not Found

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
 

HTTP Error 404.0 - Not Found when trying to access Vault Thin Client 

This issue may also occur when accessing a specific page in the Thin Client; for example, Duplicates Dashboard.

Causes:

  • The Vault Thin Client post 2022 is rewriting URLs and the rewrite URL module is not registered with IIS.
    • This can be caused by
      • Uninstalling / reinstalling IIS.
      • Upgrading from a previous Vault version.
      • Thin Client is not installed.

Solution:

Install the Vault Thin Client

How to install Thin Client.
 

Register the Rewrite Module in IIS

  1. Press the Windows Key and type inetmgr.
  2. Press Enter.
  3. Select the server name on the left side and select Modules on the right side.
  4. Select on the right side under Actions "Configure Native Modules..".
Windows IIS Manager
  1. If the RewriteModule is already there checked the checkbox and click OK.
  2. If the RewriteModule is missing, click Register and type for name RewriteModule and for path %SystemRoot%\system32\inetsrv\rewrite.dll.
Windows IIS Manager
  1. Click OK and OK and retry the operation.

Products:

Vault Professional;


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