How to download versions of Autodesk Products unavailable in the Account

Autodesk Support

Feb 14, 2025


Products and versions covered


Issue:

How to download previous versions of Autodesk Products that are unavailable in the Autodesk Account?

Causes:

The Autodesk Account supports downloading the previous three versions of any Autodesk product.

Solution:

To download up to (the latest) five versions, we recommend the following steps:

  1. Connect to Autodesk Account.

  2. Start the Autodesk Assistant by clicking the bubble in the bottom right corner of the page.

  3. Select Post Purchase support.

  4. Select Downloads.

  5. Select Downloads software.

  6. Select Find a product download.

  7. Enter the product name and version.

 

Products:

AutoCAD Plant 3D; All Desktop Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support