How to improve performance when running Autodesk Vault with antivirus software?

Autodesk Support

Mar 8, 2024


Products and versions covered


Issue:

  • Significant degradation in performance with Autodesk Vault is experienced and it might be caused by the antivirus software.
  • The general advice is given in this article on how to configure the antivirus software to prevent it from impacting client-side CAD performance.

Causes:

  • Typically, security software (Antivirus, Intrusion Prevention / Detection) will scan the most incoming and outgoing network traffic through all installed network connections.
  • This may cause serious performance degradation from the client's perspective.
  • The performance can be improved by configuring this security software to exclude certain filetypes, processes, and ports from any scanning.

Solution:

Quick Test
  • Temporarily disable all security software at every node in the network which is used for Vault Client-Server communication.
  • This will help determine if this is the cause of the performance problem. Verify if the client-side Problem can be reproduced.
 
Filetypes
Excluding certain filetypes from scanning is important to avoid performance problems. it is even more important when a remote filestore is used, as the same file will be scanned several times before it reaches its final destination.

For example, if a file is held on a remote filestore, when a user attempts to get a version, the antivirus software might scan the file in the following manner:
  1. Outbound from the remote filestore computer
  2. Inbound to the Autodesk Vault Server computer
  3. Outbound from the Autodesk Vault Server computer
  4. Inbound to the client computer
Some scanning may also occur in a router/firewall. Performance improvement is likely if these files are excluded at every node of the network journey.
 
The following is a list of commonly vaulted filetypes:
  • .dwg
  • .ipt
  • .iam
  • .idw
  • .ipn
  • .dwf
  • .dwfx
  • .dxf
  • .wdp
  • .xls
  • .xlsx
  • .doc
  • .docx
 
Processes:
In addition to vaulted filetypes, the Autodesk Vault Server /Client runs the following processes, which may need to be added to the Antivirus exclusion list:

Server:
  • aspnet_wp.exe
  • w3wp.exe
  • sqlserver.exe
  • Connectivity.ADMSConsole.exe
  • Connectivity.WindowsService.JobDispatch.exe
  •  DADispacherService.exe
  • DynamoHelperService.exe
  • All *.exe files in "C:\Program Files\Autodesk" including all sub-directories
  • Setup.exe during installation or the whole installation folder.
  • The acwebbrowser.exe process located here: "C:\Program Files (x86)\Common Files\Autodesk Shared\CLM\V7\MSVC14\cliccore\"

Client & JobProcessor:

  • CefSharp.BrowserSubprocess.exe
  • Connectivity.VaultPro.exe
  • Connectivity.Vault.exe
  • DADispatcherService.exe
  • Connectivity.JobProcessor.Delegate.Host.exe
  • JobProcessor.exe
  • CopyDesign.exe
  • Connectivity.JobProcessor.Delegate.Host.exe
  • VaultInventorServer.exe

Ports:

Typically, ports are blocked or unblocked by a firewall, which means that clients are often not able to connect to the server. However, some security software may scan the ports used by Autodesk Vault Server. If this is the case, the default port used by Autodesk Vault Server is the same port as the Default Website (Port 80).
 
Note: It is strongly recommended that you do not lower the security on any computer without a good reason. Changes to the default configuration of your antivirus software are made completely at the risk of the administrator and should only be undertaken if the implications of lowering the security are completely understood.

Products:

Vault Basic; Vault Office; Vault Professional; Vault Workgroup;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support