"Establish an Internet connection to continue" message occurs due to compromised root certificates when launching Autodesk software

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When starting an Autodesk product for Windows, this following error message appears:

Establish an Internet connection to continue

The Autodesk license server cannot be found. Various issues can cause this problem, including:

  • Internet connectivity has been lost.
  • The Autodesk license server is temporarily unavailable.

User-added image


Windows Event Viewer may show following error:

Event Name: Schannel
The certificate received from the remote server has not validated correctly. The error code is 0x80092012. The SSL connection request has failed. The attached data contains the server certificate.

Or

Event Name : Schannel
The certificate received from the remote server has not validated correctly. The error code is 0x80092012. The TLS connection request has failed.

Causes:

Compromised Root Certificates for a single-user subscription product with a serial number.

Solution:

HTTPS Inspection could break the certificate revocation check.

  • Disable this feature for *.autodesk.com.

To regenerate root certificates try the following steps.

  1. Install Transport Layer Security (TLS) updates corresponding to your Autodesk software and version.
  2. Open Certificate Manager:

a. Press Windows Start.
b. Type certmgr.msc.
c. Press Enter. 

  1. Go to Trusted Root Certification Authorities > Certificates

root certificates

  1. Remove these certificates by right-clicking and selecting Delete:
Issued ToIssued By
Go Daddy Class 2 Certification AuthorityGo Daddy Class 2 Certification Authority
DigiCert Global Root CADigiCert Global Root CA
DigiCert High Assurance EV Root CADigiCert High Assurance EV Root CA
GlobalSignGlobalSign
GlobalSign Root CAGlobalSign Root CA
Starfield Class 2 Certification AuthorityStarfield Class 2 Certification Authority
Thawte Timestamping CAThawte Timestamping CA
VeriSign Universal Root Certification Authority VeriSign Universal Root Certification Authority 
  1. Using Internet Explorer 11 (Preferred) or Chrome, visit the following websites:
    • https://www.autodesk.com
    • https://accounts.autodesk.com (as the page loads, click sign in)
    • https://cur.autodesk.com
  2. Go back to Certificate Manager > Trusted Root Certification Authorities > Certificates.
  3. From the Action Menu, select Refresh.
  4. Verify that certificates corresponding to the visited websites have been added. 
  5. Repair Autodesk software from Windows Control Panel
    1. Open Control Panel > Programs > Programs and Features.
    2. Right click Autodesk software and select Uninstall/Change.
    3. Select Repair or Reinstall and proceed with the program configuration wizard.

Note: If domain has a GPO that restricts third-party certificate registration or revocation, consult the following article:
Single-user or sign in option is missing from the Let's Get Started Screen due to compromised root certificates

Products:

All Desktop Products;


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