How to reset Revit to the installation defaults

Autodesk Support

Jan 7, 2025


Products and versions covered


Issue:

How to restore Revit to initial installation defaults

Causes:

Problems with configuration/cache files can lead to unexpected behavior in Revit.
Resetting Revit to defaults clears these files that were modified after Revit was installed (replacing with default or empty values).

Solution:

Reset

Go through the following steps to reset Revit to the installation defaults:

Note: If you would like to see an option to do this natively in Revit, see our Revit Ideas page. You can check for existing ideas on this topic here. If there isn't an idea already posted, use the following link to post your idea: Submit an Idea
  1. Use Windows Explorer to locate and rename the following folders for example ####_OLD (replace #### with the Revit version for example Revit 2023).
Revit
  • C:\ProgramData\Autodesk\RVT ####
  • C:\Users\%USERNAME%\AppData\Local\Autodesk\Revit\Autodesk Revit ####
  • C:\Users\%USERNAME%\AppData\Roaming\Autodesk\Revit\Autodesk Revit ####
Revit LT
  • C:\ProgramData\Autodesk\RLT ####
  • C:\Users\%USERNAME%\AppData\Local\Autodesk\Revit\Autodesk Revit LT ####
  • C:\Users\%USERNAME%\AppData\Roaming\Autodesk\Revit\Autodesk Revit LT ####
  1. Open the system registry (Windows Start menu > Run > Regedit). Locate and rename the following registry keys.
Revit
  • HKEY_CURRENT_USER\Software\Autodesk\Revit\Autodesk Revit ####
  • HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Revit\Autodesk Revit ####
Revit LT
  • HKEY_CURRENT_USER\Software\Autodesk\Revit\Autodesk Revit LT ####
  • HKEY_LOCAL_MACHINE\SOFTWARE\Autodesk\Revit\Autodesk Revit LT ####
Warning! Problems caused by improperly editing the Windows registry could render your computer operating system unusable. Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft Knowledge Base at http://support.microsoft.com.
Use the Microsoft® Registry Editor only at your own risk and only after backing up the registry as well as the system.dat and user.dat files as outlined for your operating system in the Microsoft Knowledge Base and in the related solution, TS66513. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.
  1. Restart the computer.

Licensing

The reset steps above would not affect the product licensing. If encountering licensing issues, see the following article for information on how to reset this: How to change or reset a license for Autodesk software.

Clean Reinstall

If resetting to defaults doesn't clear the issue (that prompted the reset), an uninstall and clean reinstall may be necessary: How to Complete a Clean Uninstall of Revit products.

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support