How to reset the CUIx in AutoCAD Products

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

The CUIx in AutoCAD needs to be restored to its previous state or reset to its original state because of corruption to the menu system or because of mistakes made while customization.

Causes:

After customizing the CUIx, it no longer works as expected or has become corrupt, causing pull down menus or the ribbon to be unresponsive or not work. Or making some keyboard shortcuts not work.

Solution:

To reset or restore the CUIx:
  1. Type CUI at the command line in AutoCAD.
  2. In the Customize User Interface (CUI) window that opens, you may need to expand the CUI dialog by clicking on the arrow button in the lower-right corner.
  3. Under the customize tab, click on the drop-down list titled "Customizations in All Files".
  4. Right-click on ACAD (next to the AutoCAD icon at the top of the list).
    1. Select "Restore acad.cuix" to restore the CUIx to its last save state.
    2. Select "Reset acad.cuix" to reset the CUIx to its original installed state.
Reset or Restore the CUIx
 
Changes made will not take place until after you have clicked Apply and OK.

The prefix and path may differ for different AutoCAD-based products. For example, in AutoCAD LT, the file will be aclt.cuix. In earlier versions of the AutoCAD software, the customization file may be acad.cui. The applicable CUix file may also be named differently depending on the version of AutoCAD, such as:
  • AutoCAD Architecture: ACA.CUIx
  • AutoCAD Electrical: ACADE.CUIx
  • AutoCAD LT: ACADLT.CUIx
  • AutoCAD Mechanical: ACADM.CUIx
  • AutoCAD MEP: MEP.CUIx
Note: This solution applies to partial CUIx files as well.

See Also:

CUI (Command)

Products:

AutoCAD Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support