"Install error: AutoCAD for Mac The install couldn't finish Error 112" when installing AutoCAD (LT) for Mac 2021 or above

Autodesk Support

Feb 20, 2025


Products and versions covered


Issue:

Users reported that when installing AutoCAD for Mac or AutoCAD LT for Mac 2021 or above, the following appears:

 

Install error: AutoCAD (LT) for Mac 202X

The install couldn't finish.

Error 112

Install error: AutoCAD LT for Mac 2022. The install couldn't finish. Error 112

 

Environment:

macOS.

Causes:

The Install.log in ~/Library/Logs/Autodesk/ODIS shows something like the following:
Failed to install Package (upi2: {819D6BBF-8C86-30FE-A87C-4A1AFBCA4DD6} name: AutoCAD LT 2022 ) Error Code: 112 Exit Status: 2

Solution:

Verify the following solutions:
 

Uninstall and reinstall the Autodesk Licensing Service

  1. Uninstall the Autodesk Licensing Service​​​​.
  2. Reinstall the Autodesk Licensing Service.
  3. Reboot your Mac.
  4. Start the software installation again.


Check the status of Licensing service

  1. In the activity monitor check if "AdskLicensingService" exists. If it does not exist, try the following steps:
  2. In terminal run:
     launchctl print-disabled system/com.autodesk.AdskLicensingService
    if it shows "com.autodesk.AdskLicensingService" => true It means the AdskLicensingService is disabled.
  3. To enable AdskLicensingService, run the following in Terminal:
    sudo launchctl enable system/com.autodesk.AdskLicensingService"
  4. To launch the AdskLicensingService process, run the following in Terminal:
    sudo launchctl load -w "/Library/LaunchDaemons/com.autodesk.AdskLicensingService.plist"
  5. Go to activity monitor, check if AdskLicensingService exists, If exists start the installation again.

 

Run the fixaccount script

  1. Download the attached file fixaccount.zip.
  2. Double-click it to extract the file fixaccount.sh.
  3. Open Terminal (in Finder > Go > Utilities > Terminal)
  4. Type:
sudo sh
  1. Drag and drop the file fixaccount.sh into the Terminal window, the command will complete similar to:
sudo sh /Users/<username>/Downloads/fixaccount.sh
  1. Press ENTER. You will be prompted for a password. Type your Mac password (no symbols are shown as you type, this is normal). Type it and press ENTER.
  2. Run again the AutoCAD / AutoCAD LT for Mac install file.

 

Perform a Clean Clean Uninstall

  1. Follow the steps in the article How to perform a clean uninstall of Autodesk programs on a Mac.
  2. Reboot the system.
  3. Reinstall AutoCAD / AutoCAD LT for Mac.

Attachments:

fixaccount.zip;

Products:

AutoCAD for Mac; AutoCAD LT for Mac;

Versions:

2021; 2022; 2024; 2023; 2025;


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