"Installation complete. Some products failed to install." during Autodesk product installation

Autodesk Support

Jul 10, 2024


Products and versions covered


Issue:

During installation process of an Autodesk product, the following message is displayed:
 

"Installation complete. Some products failed to install."

Installation complete. Some products failed to install. 

Installation complete. Some products failed to install.

This example is for AutoCAD Electrical, but a similar message appears for other Autodesk products.

 

Causes:

There are several causes for these error messages, but generally the errors indicate problems with one or both of the following:
  • Autodesk software prerequisites.
  • Autodesk software components.

Solution:

Take precautionary steps before attempting to install again:

  • Sign in as an Administrator.
  • Empty the TEMP folder. (To open the TEMP folder, type %TEMP% in the address bar of Windows Explorer and press Enter.).
  • Disable the antivirus software. Make sure windows defender is disabled.
  • Navigate to Control Panel > User Accounts > User Account and click "Change User Accounts Control Settings." Move the slider to "Never Notify" and click OK to save the setting.

Try to install again:

Run the installer previously downloaded.

If the error repeats, download the installer again, but do not run it yet

  • Use either the Download Now method; these methods include components need to be reinstalled before attempting to install the product again. 
  • If the installer has multiple parts, download all parts and save them in the same folder (C:\Autodesk). When all are downloaded, start the first file (with 001 in its name) to start the product installer extraction process.

If the problem persists, identify failed components and restart

  • Go to the main installation log file: <Autodesk software name> Setup.log. For example, Autodesk AutoCAD 2017 Setup.log.
  • Identify the components that failed during installation. Look for problems with Microsoft prerequisites or Autodesk software core components.
  • Examples of Microsoft prerequisites: Visual C++ Redistributables, Universal C Runtime, and .NET Framework Runtime.
  • Examples of Autodesk core components: Autodesk Material Library, product language packs, product-specific packs, etc.
  • Go to Control Panel > Programs > Uninstall. Look for the Microsoft prerequisite or Autodesk software core component that failed and uninstall it.
Note: If the failed component was part of a Microsoft Visual C++ Redistributable package (for example, Microsoft Visual C++ 2015 Redistributable), uninstall all the Microsoft Visual C++ Redistributables. 

Reinstall any failed Microsoft components

If a Microsoft prerequisite was uninstalled, reinstall it manually. Microsoft prerequisites can be accessed from the Autodesk software installer (preferred). In some cases, prerequisites from Microsoft may need to be downloaded.

Perform a clean reinstall

If the solutions above do not solve the problem, you may need to perform a clean uninstall\reinstall: Perform a Clean Uninstall - Download & Install.

Products:

All Desktop Products;


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