"Install failed" error when installing Revit/Revit LT 2021 or later

Autodesk Support

Dec 16, 2024


Products and versions covered


Issue:

When installing Revit/Revit LT 2021 or later the install fails and the below message is shown:

Install failed

Please exit and restart the install.

Install failed. Please exit and restart the install. 

 

Causes:

A new version of Generative Design for Revit already installed on the machine.

  • Less than 30 GB free disk space available in the drive.
  • Corrupted Autodesk Licensing Service.
  • Corrupted Autodesk Single Sign On component (AdSSO). 
  • Corrupted installation of Revit. 
  • Invalid drive detected during install. E.g. the install log RCLEENG_2021_install.log (may also apply to other related logs) may show the following:
MSI (s) (44:74) [13:20:56:092]: Product: Autodesk Revit Content Essential-ENG 2021 -- Error 1327. Invalid drive: D:\
  • Missing manifest files detected during install. E.g. the DDA.log may show something similar to the following
    ACTION PROPERTY - ASSET FOLDER: Manifest doesn't exist: <PathToInstallMedia>\image\setup.xml

Solution:

In order to solve the issue, try the following solutions one by one testing the install after each:

Corrupted Autodesk Licensing Service 

  1. Navigate to C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.

  2. Run as Admin the uninstall.exe

  3. Download and install the latest Autodesk Licensing Service from: Autodesk Licensing Service download

  4. Try again to install Revit

Corrupted Autodesk Single Sign On component 

  1. Navigate to Control Panel and uninstall the AdSSO. 

  2. Download and install the latest version of the AdSSO from: Autodesk Single Sign On Component (AdSSO) Update for 2020 & 2021 product versions

  3. Try again to install Revit. 

Corrupted installation of Revit

  1. Perform a clean uninstall of Revit as per: How to Complete a Clean Uninstall of Revit products.

  2. Download a new copy of Revit and install the product. 

Corrupted Revit 2021 installer

  1. Navigate to C:\Users\<your_username>\AppData\Local\Autodesk\ODIS.
  2. Open the file DDA.log in Notepad.
  3. You may see at the end of the file the following error: Exit code:15.
  4. Follow the solution steps shown at "Install failed" error with Revit 2021.1.1 and DDA.log indicates exit code 15.

Conflicting version of Generative Design for Revit

  1. Open Control Panel.

  2. Uninstall Generative Design for Revit from the Control Panel.

  3. Try again to install Revit 2021.

Conflicting version of Personal Accelerator for Revit

  1. Open Control Panel.

  2. Uninstall Personal Accelerator for Revit from the Control Panel.

  3. Try again to install Revit 2021.

Remove an invalid drive from the system

  1. Open an elevated Command Prompt.

  2. Run this command:

subst t: c:\temp
  1. Run the Microsoft Installation Troubleshooter .

  2. Select Uninstall.

  3. Remove any entries related to Revit Content 2021 or Revit 2021.

  4. Repeat steps if there are several entries.

  5. Attempt again to install Revit 2021.

Missing manifest files

Redownload media files from Autodesk Account.

Install with original release

If all above solution fails, you may try to install Revit 2021 with the original first release which utilizes the legacy installer. 

  1. Contact Autodesk Support for previous version releases
  2. Once installed, make sure to also apply all the latest updates for Revit 2021. Downloads are available via  Autodesk Access (installed together with Revit 2021) or the Autodesk Account.


Use '--noupdate' option

  1. Open Command Prompt(cmd.exe) with Administrator permission.

  2. Run this command:

    "C:\Download_Path\Revit_Version\Setup.exe" --noupdate

     

Products:

Revit Product Family;

Versions:

2021; 2022; 2024; 2023; 2025;


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