“Installation incomplete. Some products failed to install. Autodesk Automation 2022 License did not install (error code: 1603)” when installing PowerShape Ultimate 2022

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

While trying to install PowerShape Ultimate 2022 the below issue occurs and the installation fails:
 

Installation incomplete. Some products failed to install.

Autodesk Automation 2022 License did not install (error code: 1603)

PowerShape 2022.jpg

Causes:

  • Checking on the AutodeskPowerShapeUltimate2022F.log in %TEMP% you find that the installation fails due to an issue while registering the software
1: LicensingCustomAction.licRegister [I] [10:31:34:151]: [CONSUMER]:  

1: LicensingCustomAction.licRegister [I] [10:31:34:152]: Running "C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\11.0.0.4854\helper\AdskLicensingInstHelper.exe" register -pk A9YN1 -pv 2022.0.0.F -cf "C:\Autodesk\PowerShape_Ultimate_2022_ML_Win_64bit_dlm\x64\AMAU\ManufacturingAutomationUtilityConfig.pit" -el GB -sn 000-00000000 -sk A9LN1 

1: LicensingCustomAction.licRegister [E] [10:31:34:225]: exit code: 100, output: (500)(error while saving feature:ENCODED{5pywJ/fogvXf8iX+iOlvnoYvdKdDYmm0+2/I8iZxJGxpiSTGUsqKT0xDvHPvVu/n77DZowxw/mzfMmNbfgG7v0Xysi+SFyXl+poxS5SpmhkPuwC1V23FNERHcQpycjtsJpjfpSfDjW5mCTB7wNQZuf+bKsNAfQaHYAjI5ptq89MqmFYKgm5APGg0Ni8fYqu+ChFuI/Y90pKCeg42e9NZYLvYvJZbFcjZ8AiO5/+BcO+PQ6oJtcVUyodgvbczUKUgfpCuJHpkVQKexCjPdcw7A+IQ+B1LBYs2spxONS9Fz1ha52lAcMEM1B0R24aD5ugh})
hint: might be caused by invalid feature for current pit file. Action ended Return value 3 

1: LicensingCustomAction.licRegister [E] [10:31:34:226]: Registering a product with key A9LN1 and version 2022.0.0.F failed 

CustomAction licRegister.8B858D99_2C63_4281_AE43_6782314CCC1B returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

MSI (s) (60:D0) [10:31:34:230]: Note: 1: 2265 2:  3: -2147287035
  • Issue in Microsoft Visual C++ Redistributable

Solution:

Solution-1

  1. Disable any antivirus and/or firewall temporarily.
  2. Uninstall the Autodesk Licensing Service. See: How to uninstall Autodesk Desktop Licensing Service.
  3. Install the latest version (at least v11) of the AdskLicensing-installer.exe. See: How to download and install Autodesk Desktop Licensing Service.
  4. Download PowerShape Ultimate 2022 using the “Browser Download” method.
  5. Extract PowerShape Ultimate 2022 in C:\Autodesk.
  6. Cancel the installation once it is prompted to install otherwise it will fail again.
  7. Open Command Prompt with Admin rights by typing “cmd” on the Windows Start button.
  8. In the Command Prompt type the code below and press ENTER 
    "C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\11.0.0.4854\helper\AdskLicensingInstHelper.exe" register -pk A9LN1 -pv 2022.0.0.F -cf "C:\Autodesk\PowerShape_Ultimate_2022_ML_Win_64bit_dlm\Setup\AutodeskPowerShapeUltimateConfig.pit" -el US
Note. “-el US” depends on the location where you are. Instead of “US” use “DE” for Germany, “Gb” for UK, “IT” for Italy, etc…
  1. Install PowerShape Ultimate 2022 again.

Solution-2

  1. Uninstall all version of Microsoft Visual C++ Redistributable from the control panel.
  2. Perform a clean uninstall PowerShape.
  3. Delete the temporary files.
  4. Restart the system.
  5. Install PowerShape.

Products:

PowerShape;

Versions:

2022;


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