"License Error - ADLSDK_STATUS_AUTH_PENDING 22:Retry limit exceeded connecting to the Service" when launching Autodesk Product

Autodesk Support

Feb 14, 2025


Products and versions covered


Issue:

When launching Autodesk Product 2020 or higher versions, the following error message is shown:

License Error

The License manager is not functioning or is improperly installed. AutoCAD will shut down now.
ADLSDK_STATUS_AUTH_PENDING
22:Retry limit exceeded connecting to the Service


License Error

 

Causes:

  • Corruption of the Autodesk Desktop Licensing Service (ADLS).

  • ADLS is missing updates.

  • The Autodesk Single Sign On component (AdSSO) is missing updates.

  • Security software, antivirusses, or security systems causing blockage or conflict. 

Solution:

Option 1:

Follow these steps:

  1. Navigate to C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing.

  2. Right-click on uninstall.exe and select Run as administrator. This will uninstall the Licensing Service. Once all files and folders are removed, the process will be complete.

  • Note: If the folder is empty, skip this step.

  1. Disable temporarily any antivirus and firewall. Refer to: Autodesk Licensing Service: Known Conflicting Applications.

  2. Download the latest Autodesk Desktop Licensing Service Update. Refer to Autodesk Licensing Service Updates for the latest version. Detailed instructions on how to install the update are highlighted on the corresponding page.

  3. Download and install the latest Autodesk Single Sign On Component. Refer to Autodesk Single Sign On Component Update for 2020 & 2021 product versions for download and install steps.

  4. Launch the software.

Option 2:

  1. If third party web browser protection (i.e. Blue Coat K9 Web Protection, ESET internet Security) is installed, either disable or uninstall it temporarily.

  2. After successful uninstallation, reboot the machine.

Products:

All Products;


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