“ADLSDK_STATUS_AUTH_PENDING 3: user canceled authorization" when launching Autodesk products

Autodesk Support

Feb 3, 2025


Products and versions covered


Issue:

Users reported that when launching Autodesk products, the following message is shown:

License Error

The License manager is not functioning or is improperly
installed. AutoCAD will shut down now.

ADLSDK_STATUS_AUTH_PENDING

3:user canceled authorization

ADLSDK_STATUS_AUTH_PENDING 3:user canceled authorization

Environment:

Windows.

Causes:

  • Corrupted Autodesk Single Sign-on Component (AdSSO).
  • The Autodesk Desktop Licensing Service is missing updates. 
  • User is missing product entitlements. 

Solution:

Uninstall and reinstall the Autodesk Single Sign-on Component (AdSSO).

  1. Go to "Programs and Features" in "Control Panel".
  2. Uninstall the "Autodesk Single Sign-On Component".
  3. Download the latest Autodesk Single Sign-On version.
  4. Install the Autodesk Single Sign-On component.


The Autodesk Desktop Licensing Service is missing updates. 

Update Autodesk Licensing Service.


Repair the Autodesk Desktop Licensing Service

  1. Stop the "Autodesk Desktop Licensing Service" from the Windows services.
  2. Rename the folder C:\ProgramData\Autodesk\AdskLicensingService to C:\ProgramData\Autodesk\AdskLicensingService.old.
  3. Install the latest version of the Autodesk Desktop Licensing Service (AdskLicensing) component. 
  4. Stop the "Autodesk Desktop Licensing Service" from the Windows services.
  5. Copy the AdskLicensingService.sds from C:\ProgramData\Autodesk\AdskLicensingService.old and paste it to C:\ProgramData\Autodesk\AdskLicensingService replacying the one in this folder. 

Important Note. The SDS file must be copied from the AdskLicensingService.old backup folder to the new AdskLicensingService folder (point 5)!


The user is missing product entitlements

Make sure you are using the correct license type.
See more at Find License Information - Download & Install.

Products:

All Desktop Products;


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