"Microsoft Edge can't read and write to its data directory:" when launching AutoCAD

Autodesk Support

Dec 11, 2024


Products and versions covered


Issue:

When starting Autodesk Products the following message is displayed:

 

We couldn't create the data directory

 

Microsoft Edge can't read and write to its data directory:
C:\Program Files\Autodesk\AutoCAD 20XX\.WebView2\1\EBwebView

 

Microsoft Edge can't read and write to its data directory

Note: The folder path may differ, depending upon product version and installation location.

Causes:

  • End-user read-write permissions.
  • Corrupted installation of Microsoft's WebView2 application.
  • Interference with Security software: 
    • Antivirus software or firewall may block or redirect traffic to a specific port.
    • Incomplete initial setup of AutoCAD and missing support files/folders within the user's Autodesk directories, possibly due to Windows profile restrictions.

Solution:

End-user read-write permissions

  • Check the permissions of the following folders to make sure read-write access is present for the current user account (it might be necessary to grant it for "Everyone"):
    • C:\Users\<user folder>
    • C:\Program Files\Autodesk

 

Corrupted installation of Microsoft's WebView2 application

Repair and/or remove/reinstall Microsoft's WebView2 application.

 

Interference with Security software 

  • Configure the exclusions for all Autodesk folders in Antivirus\Firewall\Security App. See:
  • Elevate the Windows user rights and reset AutoCAD to defaults. If that fails, manually back up and then delete the following items:
    C:\Users\<username>\AppData\Roaming\Autodesk\AutoCAD 20xx
    C:\Users\<username>\AppData\Local\Autodesk\AutoCAD 20xx
    HKCU\Software\Autodesk\AutoCAD\<Rxx.x>
    Launch AutoCAD again and allow it to perform the initial setup again.

Products:

AutoCAD Products;


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