Error code 1603 is displayed with no HTTP global bindings when installing Revit Server

Autodesk Support

Nov 9, 2023


Products and versions covered


Issue:

  • Installation of Revit Server fails with a code 1603, and the following message appears:

Installation incomplete. Some products failed to install. 
Revit Server did not install (error code 1603)

User-added image
  • The following lines are in the "Autodesk Revit Server xxxx Install.log" file.
MSI (s) (C8:8C) [##:##:##:###]: Invoking remote custom action. DLL: C:\Windows\Installer\MSICC2B.tmp, Entrypoint: WriteIIS7ConfigChanges
WriteIIS7ConfigChanges:  Error 0x80070002: Site not found for create application
WriteIIS7ConfigChanges:  Error 0x80070002: Failed to configure IIS application.
WriteIIS7ConfigChanges:  Error 0x80070002: WriteIIS7ConfigChanges Failed.
CustomAction WriteIIS7ConfigChanges returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (C8:90) [##:##:##:###]: User policy value 'DisableRollback' is 0
MSI (s) (C8:90) [##:##:##:###]: Machine policy value 'DisableRollback' is 0
Action ended 14:11:45: InstallFinalize. Return value 3.

Causes:

The installer expects certain HTTP bindings. (Installation will fail if they are not available).

The default HTTP Bindings (highlighted in blue):
Global HTTP Bindings

Solution:

Do one of the following to install Revit Server:
  • If the changes to the default bindings are not needed, remove the modified bindings and add a single global HTTP binding.
  • If modified settings need to be maintained:
  1. Temporarily add a single global HTTP binding.
  2. Install Revit Server.
  3. Remove the added binding.
Note: The IP address for HTTP binding has to be a wildcard ( * - Asterisk symbol), not a particular IP address.

The following video shows how to add the global HTTP binding:

 

Products:

Revit;


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