Filestore replication does not work from Vault Server with function "Replicate now" or the Scheduled Replication

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

Replicating files from a remote Vault File Server using the "Replicate Now" or the "Scheduled Replication" commands from the ADMS (Autodesk Data Management Server) Console does not work. You may also see the following error in the AVFSConsole log file:-

Event Processing: Error raised while executing scheduled event: Autodesk.Filestore.Replication
Exception: WebServiceError [8005] (http://Servername/)

Exception(Inner): The request channel timed out while waiting for a reply after 00:01:00. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.
 

An error similar to the following may also appear, indicating

"Unable to Get/Checkout Files"
"The principal does not meet requirements to call this service":

https://help.autodesk.com/sfdcarticles/img/00P3g00000ScT1OEAV

Causes:

  • Autodesk Data Management Job Dispatch service is not running or needs to be restarted.
  • The connection to the remote server has timed out. This could happen for various reasons like:
    • If the latency to the remote server is too high.
    • Network performance between the two servers is not good.
    • The number of files takes some time to be calculated by the server.

Solution:

Job Dispatch Service

  • Check that the Autodesk Data Management Job Dispatch service is running on the Vault Server. If it is running, try restarting the service. 


Web.config timeout value

  • Increase the timeout values in the web.config file on both the local and remote Vault Servers by using following steps:
Note: Before editing the web.config file, first make a copy in case it needs to be reverted. If a mistake is made that corrupts the web.config file and no backup exists, it will be necessary to uninstall and reinstall the Vault Server.
  • web.config file locations:-
    • Autodesk Data Management Server (ADMS).
      • C:\Program Files\Autodesk\ADMS Professional [year]\Server\Web\Services
    • Autodesk Vault File Server (AVFS).
      • C:\Program Files\Autodesk\Vault File Server [year]\Server\Web\Services
  1. Look for the section, where it states "MtomCalls" and "RemoteCalls":
User-added image
  1. Increase (Double) the timeouts in bold.
  2. Save the web.config file.
  3. Start a Command prompt as an Administrator.
  4. Type IISRESET.
Note: IISRESET might interrupt ongoing end-user operation.
  1. Press Enter.
  2. Retest.
  3. If the problem persists, increase the values in Step 2 again.
 

Products:

Vault Professional;


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