Resetting Civil 3D User Profiles to default doesn't work with localized Civil 3D installations

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

After resetting Civil 3D User Profiles to default and starting Civil 3D to run the secondary installer, an error message appears that the C3D.cuix could not be found:

C3D CUI Civil 3D 2022_ITA.pngimage.png

 
 

Causes:

User profiles are not fully recovered from the path ..\Program Files\Autodesk\AutoCAD <YEAR>C3D\UserDataCache\Support

Solution:

There is often an extra step needed when resetting Civil 3D to defaults in non-English (Localized) installations, especially in 2022 and newer. Reset the Civil 3D User Profiles as per How to reset Civil 3D to defaults with the following modification:
  1. In addition to the registry key corresponding to your installed Civil 3D language (refer to the table in the List of Local Language Code for Autodesk), look for a key for the English version like: "ACAD-5100:409".
  2. Rename or delete both keys during your manual reset.

Products:

Civil 3D;

Versions:

2022;


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