"Problem installing Fusion" during Fusion installation

Autodesk Support

Dec 4, 2024


Products and versions covered


Issue:

The following message may appear when trying to install Fusion:

Problem installing Fusion

What's wrong?

We are not sure what is preventing installation.

What should I do?

Check if you are experiencing any of these known issues and follow the given recommendation. 

If Fusion 360 still does not install, collect the log files and contact us through Fusion 360 Support Forum for help.

Problem installing Fusion 360 error message

 

Causes:

Installation log files may help with understanding the error messages and their causes.
Find the installation logs at the following location:
  • Windows - C:\Users\***\Appdata\Local\Autodesk\autodesk.webdeploy.streamer.log 
  • macOS - Macintosh HD>Users>***>Library>Logs>autodesk.webdeploy.streamer.log
 

Search for the following in the installation log files and refer to the following for the corresponding solution:  

  • Errno.
  • SSL.
  • Socket.
  • Connection.
  • Gaierror.
  • Getaddrinfo.
  • Timeout.

Solution:

First, try this troubleshooter form to solve the most common issues causing issues installing Fusion.
Then attempt the following:


Repair Fusion

Repair Fusion using the Service Utility, refer to: Overview of Repair Fusion Command from Fusion Service Utility

 

[Errno 13] Permission denied

  • Make sure to have full read/write privileges to the installation directories. 
  • Create an admin profile on the same computer and install Fusion on it. If the installation is successful, there might be permission limitations on the original profile.
  • Try resetting the computer. In macOS, it is important to distinguish between restart and reset. A restart may not completely clear the issue. Shutting off the computer and then back on should reset the full computer. 
  • Antivirus security software can sometimes block the Fusion install. Check this by disabling any antivirus and trying again. The antivirus can be turned back on once the installation is complete. 


[Errno 22] Invalid argument

  1. Restart the computer. 
  2. Close any Autodesk Account desktop applications. 
  3. Open File Explorer. 
  4. Navigate to %localappdata%/Autodesk. 
  5. Delete/rename the Webdeploy and Web services folders. 
  6. Reinstall Fusion. 


SSL

Quit the installer and run it again.


Socket 

  • Quit the installer and run it again.
  • Antivirus software or firewall might be blocking the installation. Check the antivirus software to understand why the Fusion installation was blocked. The security settings may need to be modified or temporarily disabled to install Fusion.
  • Reset Internet Options. 


Connection


Gaierror

Add exceptions for Fusion to the firewall and antivirus software or disable the antivirus software. Refer to:


Getaddrinfo

Add exceptions for Fusion to the firewall and antivirus software or disable the anti-virus software. Refer to:


Timeout


Old Installer used

  • The new Fusion installer does not contain the "360" in the name and has an orange icon. 
  • Download the latest version of Fusion from the Autodesk Account to install it. 

Products:

Fusion;


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