Issue:
After making changes in a Revit local file, it won't save or synchronize.
Causes:
Damaged families within the Revit model.
Solution:
To resolve the issue use the following steps to find the damaged families:
Initial Troubleshooting
- Ensure all users are updated to the latest build of Revit.
- Open the project with the Audit checkbox selected. If the model will not open when auditing, go through the steps in the article: Cannot open or save file with audit in Revit .
- Once the model has opened successfully, open the latest journal file recorded and look for lines similar to the following:
' 3:< ======== BEGIN Dump Content Doc Tree (audit) ========
' 3:< [Family Name], LoadedId = [Element#], GUID = 6ec8b336-60db-4ece-84d9-f9ff6da57711, refers to a NON_EXISTENT_CONTENT_DOC. Please reload!
OR
[Family Name], LoadedId = 5307850, GUID = 716c9bc9-2e7c-4333-8e6c-702ca06b80bb, OwnerId = -1152388 DOES_NOT_EXIST. Please reload!
' 3:< ======== END Dump Content Doc Tree (audit) ========
- Reload the associated families (from a backup or family library) for any lines found (the line will start with the name of the family).
Note: When reloading families, use the Load Family command or open the family first and use Load into Project (avoid right-clicking on the family in the Project Browser and selecting Reload).
Reloading larger numbers of families
If there are a large number of families to reload, use the following steps to more quickly reload them:
- Find good copies of the affected files (this could be from a family library or from a different project file). To get the families saved out of an non-corrupted project file, use the Save As > Library > Family option.
- Create a separate folder to place the families that need to be reloaded.
- Place a copy of the families that need to be reloaded into the folder.
- Open the Revit model.
- Drag all of the families from the folder into the project window.
- When prompted to overwrite the first family, check the box "Do this for all loading families." If prompted regarding overwriting again, check this box again.
Shared Families
If Revit displays a warning like the following, more care may be needed to successfully reload the families:
If the message above is displayed, go through the following steps:
- Note the name of the family, and check if it is on the list of families that need to be reloaded.
- Use the option “Use the existing sub-component family that is in the project."
- Once finished reloading the other families, manually reload any bad families that were noted in the dialog above.
Note: This message relates to the loading of a nested shared family. If the nested family is reloaded then this could impact other families which also use this family. If one or more of those other families are also damaged, then the attempt to reload the nested family in the bad family before it is reloaded could lead to errors or deletion of the bad family.
If other errors/warnings are encountered when reloading the families (using the above steps), do the following.
- Identify the specific families that are leading to an error/warning. The message may appear immediately after clicking the Overwrite option for the family, or it may appear after reloading a few families of the same category.
- Reload the families that do not lead to an error/warning.
- For the families that show an error/warning, try individually reloading them by right-clicking on them in the project browser and then clicking Reload (then select the family file and click OK).
- If right-clicking and selecting Reload does not work, try opening the family and using the Load into Project command.
Note: Should none of the above steps of reloading the family resolve the issue, delete the affected families from the project library (note, that the family instances placed in the project will be deleted as well).
Products:
Revit Product Family; Revit Cloud Worksharing;