Revit Journal records "Unable to get hubs" when working with cloud models

Autodesk Support

Jan 17, 2025


Products and versions covered


Issue:

When working with cloud models, there is an issue with links or uploading new model to cloud, and the following entry is recorded in the Revit journal:
Collaborate: CloudResourceManager.GetHubs: Unable to get hubs, System.ArrayTypeMismatchException: 'Attempted to access an element as a type incompatible with the array.'

Causes:

  • Add-on loaded into Revit
  • Network blockage

Solution:

Add-on

C:\ProgramData\Autodesk\ApplicationPlugins\AlphaBIMbundle\Contents\<Version>\Newtonsoft.Json.dll

 

Network blockage

  • Office Network
Work with your IT support to check for network security services (running on the network or your system) that could be blocking Revit. See the following article for information on URLs that need to be accessible to Revit for Revit cloud workflows: Revit Cloud Worksharing: Proxy Server and domain exceptions
  • Home Network
If working on a home network (without IT support), try the following:

Products:

Revit;


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