Revit Model crashes with varying error messages

Autodesk Support

Aug 8, 2024


Products and versions covered


Issue:

A Revit model keeps crashing with messages such as: "too many missing elements," "an unrecoverable error has occurred," and so on.

In the Revit journal, you see the following line:

ApplicationException is being thrown on behalf of the function <bool __cdecl FilterCategoryRule::setCategories(const class crs::Set<class ElementId,struct std::less<class ElementId>,class tnallc<class ElementId>

Causes:

There is a problem with the Revit.ini file in C:\Users\<username>\AppData\Roaming\Autodesk\Revit\Autodesk Revit <version>.

Solution:

Locate the Revit.ini file here: C:\Users\username\AppData\Roaming\Autodesk\Revit\Autodesk Revit xxxx
Replace it with the Revit.ini file found here: C:\ProgramData\Autodesk\RVT xxxx\UserDataCache

To replace the file:

  1. Close all instances of Revit.

  2. In C:\Users\username\AppData\Roaming\Autodesk\Revit\Autodesk Revit 2017, locate Revit.ini. Save a copy of this file to your desktop. (You will overwrite the original copy of this file in step 4, so keep a copy until the process is complete.)

  3. In C:\ProgramData\Autodesk\RVT 2017\UserDataCache, locate Revit.ini, and copy it to the clipboard (Ctrl+C)

  4. Go back to C:\Users\username\AppData\Roaming\Autodesk\Revit\Autodesk Revit 2017 and use Ctrl+V to paste the copy of Revit.ini into this folder (overwriting the existing copy).

  5. Open Revit to test whether the problem is resolved.

Additional Troubleshooting

If the information above does not lead to a solution, see the following guide for other possible causes of this error: Guide: An unrecoverable/fatal error has occurred when using Revit

See Also:

 

 

Products:

Revit;


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