Revit Server process cannot access file because it is being used by another process

Autodesk Support

Jan 3, 2025


Products and versions covered


Issue:

When trying to synchronize a Revit Server model (or create a new local file) the message “This operation could not be completed…” is received and lines like the following are found in the ModelService.log:
---> System.IO.IOException: The process cannot access the file 'C:\ProgramData\Autodesk\Revit Server 2016\Projects\[Project Name]\[Model Name]\Data\###_#####.rws' because it is being used by another process.
 

Causes:

A process is interacting with Revit Server data and preventing access.
 

Solution:

To track down the conflicting process use the Microsoft Process Monitor utility to find what is accessing the file(s).
 
To setup the filters (so that the utility can run for a few days) go through the following steps:

  1. Launch the Process Monitor utility.
  2. Remove any existing filters (this ensures that we are only filtering by the filter specified in the next step).
  3. Add one new filter: Path | Contains | (include the path to the affected project)
    Note: If the error is always with a particular RWS file, include the full path to the file including the file name (this will reduce the amount of data to sort through).
  4. Set the utility to drop filtered events (this prevents a large amount of data from accumulating while waiting for the error to re-occur).
  5. Once the error occurs note down the approximate time.
  6. Review the ModelService.log to find the specific RWS file or files that could not be accessed.
  7. Look for events relating to these files around the time that the error occurred.
  8. If third party processes are found (e.g. antivirus, backup, etc.) temporarily disable these applications/services and verify that the error is cleared.
  9. If a specific third party process is confirmed as causing the error, check the application/service documentation for information on preventing it from interacting with the Revit Server files (at least when users will be working).

 
Here is a video showing the process of setting up the filters within the Process Monitor:

 

Additional Articles

For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

Products:

Revit;


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