Issue:
Revit server support files get unexpectedly big, while other users support files stay normal.
Causes:
The "central model" on the central/host server is actually a folder with several subfolders. The Data and Permissions subfolder contain all of the data directly related to the central model: that model's geometry, and all of the permissions state associated with it. The sum of these folders is reported through the Model Size column. Everything else counts towards the Support Files column - for more information check the "See Also" section.
Solution:
Please, follow these steps first in order to fix the issue:
- Open the model detached
- Delete the original model from the Revit Server
- Save the detached model back as the same name. (This will remove all the previous support files and should fix the model for the future)
- Keep tracking of the support file size and check the network reliability.
- Discourage users to terminate Revit in the middle of an operation in the Revit server environment
See Also:
Of importance in the context of this discussion is the Users_Temp folder, which is included in the "everything else" bucket. When Revit updates the central model during a SWC, it is actually updating a number of files to the central/host server. These updates are an all-or-nothing affair; if only some were to get updated, the model would be rendered unusable. Thus, when the update is in progress, the data is actually saved to a temporary area. The data is only committed after all of the files have arrived intact on the server, and following this the temporary area is cleaned out.
This temporary area is a folder beneath Users_Temp. Thus, if the support files size is more than a few MB large, it is likely that someone's SWC (Synchronize with Central) has failed. It is normal to see this value periodically increase, but in general it should also reduce. If the support file size remains high but is generally static, it is possible that someone attempted to SWC, left files behind, and never tried again for that model. Growth in the supported file size, or a supported file size that is variable but generally large, could be symptomatic of a problem with network reliability, because this will generally indicate that SWCs are failing to succeed somewhat regularly. If the growth is attributable to a specific user (or certain users) it could indicate that those users have developed the habit of terminating Revit in the middle of an operation. This should be discouraged.
When a model is deleted from the server and then created anew, the entire model folder structure including the Users_Temp area is recreated. Thus, the support files size will always reset to a baseline value.
Products:
Revit Product Family;
Versions:
2017; 2013; 2014; 2015; 2016;