"There was an issue with enabling worksharing. This operation could not be completed..." when enabling worksets for a specific Revit Cloud model

Autodesk Support

Jan 2, 2025


Products and versions covered


Issue:

When trying to enable worksets for a specific Revit Cloud model, the following message appears:

Enable Worksharing

"There was an issue with enabling worksharing.

This operation could not be completed. Please try again."

Enable Worksharing Error.png

In addition, the following entries can be found in the journal file:

' 0:<   System.ServiceModel.FaultException`1[Autodesk.Revit.RS.Common.ClientServer.DataContract.Model.PermissionSourceCorruptionFault]: Internal Server Error

Causes:

The model has been corrupted and repair is needed.

Solution:

See the following article for information on recovering a backup version of the model:
"Data in file (file name).rvt is corrupt and needs to be manually recovered" when opening a file or syncing a file to central in Revit

Products:

Revit; Revit Cloud Worksharing;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support