"This operation could not be completed. Please try again..." when browsing or syncing to central on Revit Server

Autodesk Support

Jan 3, 2025


Products and versions covered


Issue:

When browsing or syncing to central on Revit Server, the following message appears, which may be specific to one particular workstation:

Operation Could Not Be Completed

This operation could not be completed. Please try again.
If you are collaborating on a model using the cloud or Revit Server, check your network connection.
If the problem persists, save any changes to the models locally.

Screen of the warning message about operation not completed

When opening the Revit journal file from the session, it may contain the following entries:
Autodesk.RevitServer.Enterprise.Common.ClientServer.Helper.Exceptions.ProxyGenerationException: A problem occurred generating a proxy for the client action, Client Action = BasicAction, Target Node = 192.169.1.11, Binding Name = tcpbuffer 
' 0:< System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://192.169.1.11/ModelService2020/ModelService.svc/tcpbuffer. The connection attempt lasted for a time span of 00:00:21.0028635. TCP error code 10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.169.1.11:808. 
' 0:< System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.169.1.11:808
 
 
 

Causes:

  • The Revit Server host is not responding.
  • The connection between Revit (client) and Revit Server host is not opened on the required port.

Solution:

Use one of the following to capture a specific cause:


Check Connection to Server

  1. Check whether TCP Activation is installed in the Features panel of Server Manager: Server System Prerequisites
  2. Enable the Telnet Client.
  3. Use Telnet to connect to the server on port 808, for example (replacing 192.168.1.1 with the server's IP address):
telnet 192.168.1.1 808
  1. Depending on the result:
    • If the result is "Could not open connection to the host, on port 808: Connect failed", work with your Computer/Network support to enable the connection between the workstation and server.
    • If the Telnet connection is successful, the workstation should be able to communicate with the server. (There is no message for the successful result).

Note: Ping can be used as an initial test for connectivity but does not use the same port as Revit Server traffic (808), so Telnet is a better test.

 

    Check RSN.ini

    • Confirm that the RSN.ini file contains the name or IP Address tested in the prior step.
    • To rule out DNS issues, try adding the IP Address to the INI file (if not already used).

    Note: If accessing through the IP address works, there is an issue with resolving the IP address to the hostname (DNS). Work with your computer/network support to resolve this.

    Additional Articles

    For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

    Products:

    Revit;


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