"This operation could not be completed. Please try again..." when opening a newly saved model from Revit Server

Autodesk Support

Jan 3, 2025


Products and versions covered


Issue:

When opening a newly saved model from Revit Server, a following error message is displayed:

Operation Could Not Be Completed

"This operation could not be completed. Please
try again.

If you are collaborating on a model using the cloud or Revit
Server, check your network connection.

If the problem persists, save any changes to the models
locally."

Error.png

There is no problem with saving models and browsing them later on Revit Server. The issue is only when opening models. The following entries can be found in the journal:
 

'0:< Message inside RevitServerClientSideException: An exception caught in RSEnterpriseClientInterop during operation handleServerException: Type=UnauthorizedAccessException, Message : Access to the path is denied. 
' 0:<  1 ModelServerState "Created": Current server = ":<Not Determined>", Model server = "###.###.###.###", Model server state = "Internal Error" 
' 0:<  0 ModelServerState "Destroyed": Current server = ":<Not Determined>", Model server = "###.###.###.###", Model server state = "Internal Error" 
' 0:< SLOG $5950fd86 2021-06-02 10:40:32.795 <CutLocal 
' 0:< SLOG $5950fd86 2021-06-02 10:40:32.796 <Session 
' 0:< TaskDialog "Revit cannot create a local copy from the central file RSN://###.###.###.###/New model 1/test.rvt. "

Environment:

Installed Revit Server a local server on the LAN with the same version as Revit.

Causes:

A cloud-based data backup application such a: Dropbox, Google Drive or OneDrive has a selected folder: C:\Users\<user name>\Documents for synchronization. When opening a model from Revit Server, Revit cannot access the temporary files in this location.

Solution:

To resolve this issue, try one of the following.

Change the location of the default saved user files in Revit

  1. Click File tab Options.
  2. Select 'File Locations' from the list.
  3. Change the 'Default path for user files' location and specify the folder that is not synchronized by the cloud storage application.
User Files.png
  1. Click OK.

Uncheck the Documents folder from the list of those to be synchronized

  1. Go to the cloud storage application settings.
  2. Uncheck the Documents folder from the list of synchronized folders:

Additional Articles

For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

Products:

Revit;


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