"This operation could not be completed" appears when opening certain cloud models in Revit

Autodesk Support

Feb 11, 2025


Products and versions covered


Issue:

When opening certain cloud models in Revit, the following message appears:

 

Open Model

Opening model: <Model Name>
This operation could not be completed. Please try again.

Screenshot of "This operation could not be completed..."  message that appears opening a specific model in Revit.


The Revit journal records lines like the following preceding the error:

Failed to load elemStream####
captureTryCrash 0xe06d7363
...
'status: ERROR : Cannot connect to central model 
0:< openDocumentFileForUI: Unknown exception 
0:< Unhandled exception - exception: Autodesk.Revit.Exceptions.FileAccessException, msg: Unexpected structured EXCEPTION_ACCESS_VIOLATION happened during open documents.. 
  • Sometimes, Revit crashes when opening workshared models.

Causes:

  • Corrupted local cache.

  • Damaged Model.

  • Antivirus interfering with Revit writing to cloud cache folders.

  • Damaged Revit installation.

Solution:

Revit 2024

If working with Revit 2024, and not updated to 2024.3.1 or later version, try updating. The following article has more info on this behavior specific to the 2024 version: Freeze, crash, or "This operation could not be completed" while opening file in Revit after upgrade to 2024.3.

Host versus Link

  • Check if the message is showing up when opening the host model, or a linked model.
  • This can be seen by clicking the Show Details option in the cloud opening dialog:

Image of Revit Open Model Dialog Box.

  • Link: If a link triggers the error, open it directly to clear potential warnings.

  • Host: If the message occurs when the host is being opened, or the link cannot be opened, clear the cache.

    • Rename the following folders to include _OLD

      • C:\Users\%username%\AppData\Local\Autodesk\Revit\Autodesk Revit 202X\CefCache

      • C:\Users\%username%\AppData\Local\Autodesk\Revit\Autodesk Revit 202X\CollaborationCache

      • C:\Users\%username%\AppData\Local\Autodesk\Revit\PacCache

        1. Might have to exit the Personal accelerator from Task manager first. 

        2. Restart the personal accelerator after clearing the cache.

          C:\Program Files\Autodesk\Personal Accelerator for Revit\RevitAccelerator.exe

Affected Members

Reset Revit

If the previous steps don't help, see the following article for information on How to reset Revit to the installation defaults.

Other Articles

For more articles on this error, see the following link: "This operation could not be completed." when opening cloud model in Revit.

Products:

Revit Product Family; Revit Cloud Worksharing;


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