"This operation could not be completed..." when synchronizing a specific file to Revit Server

Autodesk Support

Dec 19, 2024


Products and versions covered


Issue:

  • Users reported that when synchronizing a specific model on Revit Server, the following messages appear:

Operation Could Not Be Completed

This operation could not be completed. Please try again.

If you are collaborating on a model using the cloud or Revit Server, check your network connection.

If the problem persists, save any changes to the models locally.
 
Screen of the message "This operation could not be completed."
  • The following message may also be displayed: 

Revit

File not saved.

Screen of the warning message "File not saved."
  • One or more of the following entries can be found in the journal file:
    • System.ServiceModel.FaultException`1[Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault]: invalid record 
    • System.ServiceModel.FaultException`1[Autodesk.RevitServer.Enterprise.Common.ClientServer.DataContract.System.ServiceFault]: Root element is missing. 
  • An entry similar to the following may be visible in the ModelService log:
ERROR TID(#) LOGGER(ServerLogger) MSG(Exception: (PermissionSourceOpenFailedException, Root element is missing.)(XmlException, Root element is missing.)

Causes:

The Revit model is corrupted.

Solution:

To resolve the issue, use one of the following solutions. 

  • Recover the model from a backup.
  • Recreate the Revit Server host model from the local copy:
    1. Open a project member's local copy with the "Detach from Central" option selected.
    2. Choose the "Detach and preserve worksets" option.
    3. Save it as a new central model on the Revit Server.

Additional Articles

For more articles on this error, see the following article "This operation could not be completed. Please try again" when working in Revit Server

Products:

Revit;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support