Troubleshooting Inventor stability, crash and hanging issues

Autodesk Support

Feb 18, 2025


Products and versions covered


Issue:

This article provides suggestions on how to troubleshoot situations where Autodesk Inventor is unstable, freezes, crashes, or hangs (on restart, opening, saving or during use).

The following message might appear when Inventor is crashing: 

Autodesk Inventor Error Report

A software problem has caused Inventor to close unexpectedly.
Autodesk Inventor Error Report

Or

Autodesk Inventor has stopped working

Causes:

  • Recent Windows update.
  • System file corruption.
  • Model file corruption.
  • Windows user profile corruption.
  • Old graphics card drivers.
  • Add-ins not working.
  • Etc.

Solution:

Check the form below which may lead to a more direct solution based on answers. 

Guide: Troubleshooting Inventor stability, crash and hanging issues

If the issue is not resolved with the guide, follow the steps below.

  1. Install the latest graphics (video display) drivers.
    • Many Inventor stability issues are related to out-of-date or corrupt video drivers. Compare the video drivers currently installed with the latest available from the hardware vendor.
    • Ensure that the latest drivers are installed. See How do I check that I have the latest video drivers installed?.
    • If the latest drivers are installed, reinstall them. Windows updates regularly brake components used by the graphics drivers. Reinstalling or repairing the same, latest drivers can fix many stability issues.
    • Make sure that the software is using high-performance graphics instead of the default graphics card. See How to configure Autodesk software to use high-performance graphics.
  2. Check Antivirus software settings, when occurs after upgrading to a newer version of Inventor.
  3. Sign in Windows as another user. 
    • Run Inventor by right-click as administrator. If this is resolved the issue, then look for the solution in Windows user access, permissions.
      • Try logging into Windows as a different user (use local Windows user for tests not domain). If the Windows User Profile is corrupted, it might not happen when logged in to the same machine but as a different user. It might be a solution for the Administrator to delete the user profile.
  4. Reset Inventor. See Use the Inventor Reset Utility to reset local settings to default values.
  5. Update the 3D mouse driver with the latest available drivers on the website. See 3D Connection drivers download.
  6. Eliminate the possibility of an Add-in causing the issue.
    1. Disable as many Inventor Add-ins as possible. See How do I disable the Inventor Addins?.
    2. Change their load behavior and deselect the Load Automatically tick box.
    3. Restart Inventor.
    4. Reproduce the issue.
    5. If the issue no longer occurs, re-enable one module at a time, retest, until the specific Inventor add-in causing the problem has been isolated.  
    6. If the issue can be easily reproduced, try using a process of elimination to isolate the cause.
  7. When some additional add-ins are used in Inventor the following issues might take place. See Inventor is crashing when GDI Objects reaches 10000.
  8. Fix all other system stability issues.

      Windows Error Reporting > Systems Information.

      1. Uninstall and reinstall Microsoft Visual C++ Redistributables. See  How to remove and reinstall Microsoft Visual C++ Redistributables packages.
      2. Check files for bad bodies according from Inventor. See How to use the Ctrl + F7 in Inventor to find bad bodies.
      3. Sign out of the Autodesk Account and sign in again from Inventor. See How to sign out of Autodesk software.
      4. Clean the workspace by deleting the local files and redownload them from Vault. See Vault Professional Help | Synchronizing Your Workspace.
      5. Uninstall and reinstall Inventor. See Uninstall Autodesk software.
      6. Test on a clean operating system with no other software.
      7. After reinstalling, test the latest updates for Inventor. See Update your software.
      8. Install the latest Windows Updates also on Windows Server if files are stored on server.
      9. Windows Update failures are often a sign of instability issues on the system in general. See How to keep your Windows computer up to date.
      10. Too long path to the files.
      11. Reinstall or install newest NetFramework. See How to repair or reinstall the Microsoft .NET Framework.

      Products:

      Inventor Products; Vault Products;


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