Troubleshooting Windows Authentication issues in Vault

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

Windows Authentication is only supported by Vault Professional
If you can log in to Vault using a Vault account, but cannot log in using Windows Authentication try the following steps.

Causes:

Windows Authentication is not configured correctly.

Solution:

Follow these steps to identify and solve incorrect settings:
  1. On the Vault Server, start Internet Information Services (IIS) Manager.
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  1. Expand the nodes to reveal:
  • Services
  • Filestore
  • AutodeskTC (if ThinClient is installed)
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  1. Select each node, then under IIS settings, double click "Authentication", or right click and select "Open Feature".
 
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  1. Ensure for each node that Windows Authentication is "Enabled". If there is no Windows Authentication, check in Windows Features to make sure everything is installed.
 
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  1. Right click and select "Providers" for each nodes Windows Authentication settings.
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  1. In Providers, ensure that Negotiate and NTLM are listed and in that order.
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Also make sure the server is bound to the domain controller and there exists a two way trust. A quick un-bound and re-bound to the Windows Active Directory (AD) also helped in some of the situations.

Client side Troubleshooting

Enabling Auditing on the Vault client:
  1. On the Vault client, press the key Windows + R at the same time. This displays the "Run" window.
  2. Type secpol.msc and click "OK".
  3. Expand "Security Settings" > "Local Policies" > "Audit Policy".
  4. Change the Security Setting for:
  • Audit account logon events.
  • Audit directory service access.
  • Audit logon events.
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  1. Retry the login to Vault.
Errors will be logged in the Windows Event Viewer.
Troubleshoot the errors found in the Windows Event Viewer using a web search engine.

See Also:

If you are connecting to Vault Server through a VPN, see this article:

Troubleshooting client connections to Vault Server through a VPN (Virtual Private Network)


If the issue persists, follow the steps in this article:

Troubleshooting Autodesk Vault Client to Server Connectivity issues


Note: The list of steps in the above article, can be daunting to some. Consider, that it could take 30 minutes to uninstall and reinstall Vault Server and all its components:

Components installed by Autodesk Vault (Server and Client)

Products:

Vault Professional;


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